İçindekiler Giriş ACD ChemSketch programının tanıtımı

Yorumlar

Transkript

İçindekiler Giriş ACD ChemSketch programının tanıtımı
ACD ChemSketch 12.0 ile kimyasal formüller nasıl çizilir?
Hazırlayan:
Uz. Dr. Barbaros Akkurt
İstanbul Teknik Üniversitesi
Fen-Edebiyat Fakültesi
Kimya Bölümü
Anorganik Kimya
34469 Maslak, İstanbul
e-posta: [email protected]
İçindekiler
Giriş................................................................................................................................ 1
ACD ChemSketch programının tanıtımı............................................................................1
Nereden indirilir?.........................................................................................................2
Nasıl kurulur?..............................................................................................................2
Temel özellikleri nelerdir?............................................................................................2
ChemSketch ile çizilen bazı örnek yapılar................................................................3
Ticari sürüm ile bedava sürüm karşılaştırması.............................................................3
ACD ChemSketch programında şekil çizimi......................................................................3
Kolay kopyalama yöntemleri.......................................................................................3
Sübstitüent ekleme: Klorobenzen................................................................................4
Başka bir sübstitüent ekleme: o-diklorobenzen...........................................................5
Karbon-heteroatom değişimi: Piridin............................................................................5
Sübstitüent ekleme: Izonikotinik asit...........................................................................5
Radikal Tablosunu kullanma: Serin aminoasidini iki yöntemle çizelim..........................5
Yapı (Structure) ve Çizim (Draw) kipleri.......................................................................5
Periyodik tablodan element ekleme.............................................................................5
Simgesel element ekleme...........................................................................................6
R grupları ekleme........................................................................................................6
Zincir çizim aracı.........................................................................................................7
Stereokimyasal bağ ekleme........................................................................................7
Yapı düzeltme ve basit eniyileştirme araçları...............................................................7
InChi ve SMILES araçları..............................................................................................7
PubChem, ChemSpider ve eMolecules araçları............................................................9
Üst menü seçenekleri: Menülerin incelenmesi...........................................................10
Hesaplama yöntemleri..............................................................................................13
Çizim (Draw) Kipindeki araçların incelenmesi............................................................13
Giriş
Bu eserde, Advanced Chemical Development (ACD) isimli bir Kanada firması tarafından
ilk kez 1994 yılında piyasaya sunulmuş olan “ChemSketch” isimli formül çizim
programını tanıtmaya çalışacağız.
ACD ChemSketch programının tanıtımı
ACD/ChemSketch programı bedava (freeware) ve ticari (commercial) olmak üzere iki
biçimde sunulmaktadır. Doğal olarak ticari sürümde daha çok özellik vardır ve bedava
sürümdeki bazı özellik kısıtlamaları kaldırılmıştır. Piyasadaki en güçlü formül çizim
programlarından biri olan ACD/ChemSketch programını severek kullanacağınızı ümit
<1>
ediyoruz.
Nereden indirilir?
ACD/ChemSketch programını indirmek için (sunum sırasında 30 adet CD hazırladık, bu
CD'lerin içinde şu anda okuduğunuz metin, ACD firması tarafından sunulan İngilizce
dilinde yazılmış kullanım kılavuzları ve programın 12.0 sürümüne ait EXE dosyası
bulunmaktadır) http://www.acdlabs.com/ adresine tıklayarak firmanın web sitesine
bağlanıyoruz. Ekranın orta-sağ kısmında bulunan dört parçalı yuvarlak şeklin sol alt
diliminde “Desktop Products” yazmaktadır. Buradan “Nomenclature&Chemical Drawing”
kısmını seçiyoruz, Yeni sayfada sol kısımda iki seçenek bulunmaktadır. Bunlardan birisi
“Nomenclature”, diğeri de “Structure Drawing” olarak gözükmektedir. Structure Drawing
kısmını seçiyoruz ve açılan küçük pencereden ACD/ChemSketch seçeneğini işaretliyoruz.
Nasıl kurulur?
Temel özellikleri nelerdir?
ACD/ChemSketch programı, organik, organometalik, polimer ve Markush yapıları olmak
üzere hemen her tür yapıyı çizebileceğiniz kimya zekâsı olan bir bilgisayar yazılımıdır. Bu
programı profesyonel görünümlü yapılar, diyagramlar, raporlar ve yayınlar oluşturmak
için kullanabilirsiniz.
• Yapılar iki boyutlu olarak çizilebilir, üç boyutlu hale çevrilebilir ve istenen açıda
çevrilebilir.
• Tepkimeler, tepkime şemaları, reaktif miktarlarını görüntüleyebilirsiniz,
• InChi ve SMILES dizgelerinden yapı oluşturabilirsiniz,
• 50 atom ve 3 halka yapısına kadar olan bileşikler için IUPAC'ın önerdiği
isimlendirmeyi oluşturabilirsiniz,
• Tek yapılar için logP değerlerini hesaplayabilirsiniz,
• 165.000 geleneksel, sistematik ve ticari isimli yapı içinden arama yaptırabilirsiniz,
Programdan edineceğiniz faydaları da şöyle özetleyebiliriz:
• Uzaysal dizilimleri daha iyi görüntülemek için iki veya üç boyutlu olarak
molekülün gösterilmesi,
• Aynı anda profesyonel raporlar üretmek, yapılarla, metinlerle ve grafiklerle
çalışmak mümkündür.
ACD/ChemSketch yazılımı, çizdiğiniz yapının diğer tautomerik biçimlerini gösterebilir.
Tautomerik biçimlerin düşünülmesi yapı arama, pKa gibi fizikokimyasal özelliklerin
belirlenmesi, ve yapı özelliklerinin (NMR, MS ve diğer analitik veriler) bulunması için son
derece önemlidir.
ChemSketch yazılımı bir seri dosya biçimine veri kaydedebilir ve bu dosya biçimlerinden
veri alabilir. Böylece başka bir bilgisayarda ChemSketch kurulu değilse ortak bir
paylaşım biçimi kullanarak çalışmanıza devam edebilirsiniz.
<2>
ChemSketch ile çizilen bazı örnek yapılar
Ticari sürüm ile bedava sürüm karşılaştırması
İşlevsellik
Ticari Bedava sürüm
İleri çizim araçları
Var
var
Tautomerlerin bulunması
var
var
50 ağır atoma kadar olan yapıların isimlendirilmesi var
var
3D görüntüleyici
var
var
Adobe PDF biçimine aktarma
var
Var
ACD/Sözlük
var
yok
Bir yapının bilgisayarınızda aranması
var
yok
ChemDraw için ACD/Labs eklentisi
var
yok
Teknik destek
var
yok
Görüldüğü gibi bedava sürüm pek çok kuvvetli özellik içermektedir. Çalıştığınız şirkete
veya okula bir adet ticari sürüm kazandırmayı ve ortak kullanmayı düşünebilirsiniz. Ticari
sürümün bir lisansı 400 TL civarındadır.
ACD ChemSketch programında şekil çizimi
Kolay kopyalama yöntemleri
ChemSketch programında çizilmiş bir şekli Microsoft Word veya OpenOffice/LibreOffice
programlarına aktarabilirsiniz. 5.0 sürümünden bu yana tanıdığımız ChemSketch
programı ile ilgili edinmiş olduğumuz tecrübe, şekli kopyalayıp doğrudan (CTRL+V tuşu
ile veya yapıştır düğmesine basarak) yapıştırmanın iyi bir yol olmadığını anlatmaktadır.
Bunun yerine özel yapıştır fonksiyonunu çalıştırarak yapıyı bir resim (metafile-bitmapGIF-TIF-JPG vs) olarak yapıştırmak, özellikle bu programı içermeyen bilgisayarlarda metin
<3>
dosyasının görüntülenmesinde sorun çıkmasını engelleyecektir.
Kopyalama kelimesinin ChemSketch için bir başka tanımı da ChemSketch penceresi
içinde bir yapının kopyalanmasıdır. Burada az önce anlattığımız yapıştırma kısıtlamaları
yoktur. Bir yapıyı kopyalayıp yapıştırmanın klasik yolu yapıyı seçmektir. Yapıyı seçmenin
iki yolu vardır:
a) Yapıyı seçme tuşunu kullanıp yapıyı tarayarak seçmek,
b) Yapının üzerine gelmeden, çok yakınına gelerek farenin sol tuşuna bir kere basmak.
Yapıyı kopyalamak için CTRL+C tuşuna basmak veya ilgili düğmeyi tıklamak yeterlidir.
İlgili yere yapıştırmak için de CTRL+V ve yapıştırma düğmesi kullanılabilir. Ancak bizim
tavsiye edeceğimiz yöntem başkadır ve bize göre daha basittir. Az önce bahsettiğimiz
yöntemlerden size uygun olan birini seçerek yapıyı seçtikten sonra, yapının üzerine gelin
(seçim işaretinin biçimi değişecektir), CTRL tuşunu basılı tutarak yapıyı sürükleyin ve bir
kopyasını istediğiniz yere bırakın. Bu yöntemle yapıyı kolay ve hızlı bir şekilde
kopyalayabilir ve üzerinde değişiklik yapabilirsiniz. Bu yöntem yapılar ve ok şekilleri, artı
şekilleri gibi bu sayfada göreceğiniz diğer her şey için de geçerlidir.
Sübstitüent ekleme: Klorobenzen
Klorobenzen yapısını iki adımda elde edeceğiz:
1) Benzen halkasının eklenmesi,
2) Bir karbona klor bağının eklenmesi.
Benzen halkası, sağ taraftaki araç çubuğunda hazır bulunmaktadır. Herhangi bir
sebepten dolayı benzen halkasını sağdaki çubukta bulamıyorsanız, biraz üstte bulunan
Radikal Tablosu (Table of Radicals) tıklanarak bir çok radikale erişilebilir. Benzen
halkasına tıkladığınız zaman, imleçle beraber hareket eden bir benzen “gölgesi”
göreceksiniz. İmleci sizin için uygun bir yere götürdükten sonra farenin sol tuşuna bir
kere basarak yapıştırabilirsiniz. Başka bir benzen halkasına ihtiyacınız olabilir düşüncesi
ile yapıştırma işlemine devam etmeniz mümkündür, işlemleri tekrarlayarak benzen
halkalarını eklemeye devam edebilirsiniz. Başka bir benzen halkası eklemek
istemiyorsanız, farenin sağ tuşuna tıklayarak yapıştırma işlemini bitirebilirsiniz.
Bu aşamadan sonra klor atomunun eklenmesine sıra gelmiştir. Klor atomunu sol
taraftaki araç çubuğunda görebilirsiniz. Klor atomuna tıkladıktan sonra benzen
atomunun herhangi bir karbon atomu üzerine gelin, sol fare tuşuna basılı tuttuktan
sonra dışarıya doğru sürükleyin ve sol fare tuşunu bırakın. Böylece bir sübstitüentin nasıl
ekleneceğini de öğrenmiş oldunuz. Bunu yapmanın bir başka yolu daha var, onu da
açıklayalım: Benzer şekilde klor atomuna ait düğmeye tıklayıp benzen karbonuna
geldikten sonra SHIFT tuşuna basılı tutarak sürükleme yaparsanız bağ uzunluğu
eniyileştirilmiş bir şekilde sübstitüent eklemiş olursunuz. Biz bu yöntemi daha çok
seviyor ve kullanıyoruz. Eğer ilk yöntemle sübstitüent eklemişseniz ve bağ uzunluğu
veya açısı sizi tatmin etmemişse, ChemSketch sizin için bağ eniyileştirmesi yapabilir.
Bunu yapmak için yapıyı yukarıda anlattığımız gibi seçin ve F9 tuşuna basın ya da sağ
üst araç çubuğunda bulunan Yapıyı Düzenle (Clean Structure) tuşuna basın. Böylece
bilgisayar sizin için en uygun geometriyi oluşturacaktır. Beğenmezseniz veya başka
hangi alternatiflerin olduğunu görmek isterseniz, F9 tuşuna veya yapı düzenleme
düğmesine bir kere daha tıklayın ve sizin için uygun olan sonucu bulana kadar devam
edin.
<4>
Başka bir sübstitüent ekleme: o-diklorobenzen
Başka bir sübstitüent eklemenin, benzen halkasına tek bir sübstitüent eklemekten bir
farkı yoktur. Ancak kısaca açıklamak gerekirse klorobenzen halkasının orto konumuna
gelerek yukarıda açıkladığımız gibi ikinci bir klor atomu ilave edebilirsiniz.
Karbon-heteroatom değişimi: Piridin
Karbon-heteroatom değişimini yapmak için, bir benzen halkası alın, yapıştırın ve sol
menüden azot atomuna ait düğmeyi tıklayın ve benzen karbonlarının herhangi biri
üzerine gelip farenin sol tuşu ile tıklayın. Böylece karbon atomlarından biri azot atomu
ile değiştiğinden piridin halkasını elde etmiş olacaksınız.
Sübstitüent ekleme: Izonikotinik asit
İzonikotinik asit, piridin-4-karboksilli asittir ve benzen halkasının seçilmesi, yapıştırılması,
azotun seçilmesi, karbonla değiştirilmesi ve sağ menüden karboksilli asit radikalinin
seçilmesi (hazırda yoksa Radikal Tablosundan bulunacak) ve 4-konumundaki karbon
atomu üzerine gelip sol tuşa bir kere tıklamakla kolayca çizilebilir.
Radikal Tablosunu kullanma: Serin aminoasidini iki yöntemle çizelim
Radikal tablosu, ihtiyacınız olabilecek pek çok grubu barındırmaktadır. Bunların içinde
amino asitler de vardır. Serin aminoasidinin üç harfli kısaltması Ser olduğu için, radikal
tablosunun sağ üstünde yer alan aminoasitler kısmından serin aminoasidini bulup
tıklayarak editör ekranına dönebilir ve uygun yere gelip bir kere tıklayarak serin
radikalini ekleyebiliriz. Serin aminoasidinden tek farkı COOH grubunun OH kısmının
olmamasıdır, basit bir sübstitüsyon ile bu kısmı da halletmeniz mümkün.
Böyle kolay bir yöntem varsa da şimdilik çizim tekniğinizi oturtmak için uzun uzun çizim
yapmak kabul edilebilir. Bunun için çizmeye istediğiniz taraftan başlayabilirsiniz. Bir
COOH grubunu ekliyoruz, CH3 grubu ekliyoruz, ona NH3 grubu ekliyoruz, eklenen C
grubuna bir CH3 grubu daha ekliyoruz ve son olarak OH grubunu ilave ederek çizimimizi
tamamlıyoruz.
Yapı (Structure) ve Çizim (Draw) kipleri
Yapı (Structure) ve Çizim (Draw) kiplerinde ChemSketch programının iki kuvvetli yönünü
göreceğiz. Yapı (Structure) kipinde yapıları çiziyoruz. Çizim (Draw) kipinde ise yapıya ait
bazı özellikleri (yazıtipi değiştirme, boyut büyütme/küçültme, renk değiştirme, bağ
uzunluğu ve bağ rengi değiştirme gibi) ayarlıyoruz. Bir yazı yazmak istediğimiz zaman
Çizim kipini kullanacağız. Daha sonra da anlatacağımız üzere yazı yazmak için
kullanacağınız iki değişik düğme var, biz Metin Düğmesi (T biçiminde) kullanmayı tercih
ediyoruz. Yapı ve Çizim kiplerinin arasında sık sık gidip geleceksiniz. Bunun için SPACE
tuşunu kullanmak büyük kolaylık sağlar. Alternatif olarak ekranın sol üst tarafında
bulunan düğmeleri de kullanabilirsiniz. ChemSketch yazılımı, sizin rahat ve konforlu bir
ortamda kimyasal formül çizimi yapabilmeniz için elinden geleni yapmıştır.
Periyodik tablodan element ekleme
Biraz önce azot, oksijen elementlerini nasıl ekleyeceğimizi öğrenmiştik. Tazeleme amaçlı
<5>
olarak tekrarlamak istiyoruz. Metal komplekslerini çizerken önce ligandı (organik veya
anorganik yapıyı), sonra metali eklemek bizce en uygun yoldur. Şimdi, az önce çizmiş
olduğumuz serin aminoasidinin çinko kompleksini ekleyelim. Silmişseniz serin
aminoasidini yukarıda bahsettiğimiz yöntemle bir daha ekleyin. Daha sonra ikinci bir
ligandı ters çevirerek eklememiz gerekiyor. Bu size başta biraz zor gelebilir. Ancak
anlattıktan sonra siz de deneyince kolayca alışacağınızı umuyoruz. İkinci serin ligandını
kopyalayıp yapıştırdıktan sonra Flip Top to Bottom ve Flip Left to Right (üst menüde sağ
tarafa doğru bulabilirsiniz) düğmelerine istediğiniz sıra ile birer kere basarak yapının
uygun şekilde dönmesini sağlayın. Aradaki boşluğa (dört oksijenin oluşturduğu boşluğun
ortalarında bir yere) çinko atomunu ilave edin. Büyük ihtimalle listede bulunmadığı için
sol üst taraftaki element tablosunu açıp çinko atomunu seçin ve ortadaki boşluğa bir
kere tıklayarak yapıştırın. Şimdi bağ oluşturma aşamasına geldik. COOH türleri ile Zn
türü arasında düz çizgi, alkol OH türü ile Zn türü arasında koordinasyon bağı olması
uygun olacaktır. Metal-oksijen arasındaki düz çizgi daha önce bahsettiğimiz sübstitüsyon
ile aynı şekilde (oksijen atomuna tıklayıp çinko atomuna doğru sürükleyerek) yapılabilir.
Sizin için yeni olabilecek koordinasyon bağı da ChemSketch'te tanımlanmıştır.
Koordinasyon bağı Coordinating [Arrow] Bonds düğmesine tıklayarak olur. Koordinasyon
bağlarının eklenmesi ligand donör atomundan metal atomuna tıklayıp sürükleyerek
kolayca eklenebilir.
Simgesel element ekleme
Simgesel elementler (programda “label” olarak tanımlanmıştır) veya etiketleri eklemek
için kolay bir yol var. Diyelim ki uzun uzun heksil grubu yazmak, yani altı tane CH 2
grubunu eklemek istemiyorsunuz, o zaman C6H13 diye bir grup oluşturabilir ve ihtiyacınız
olduğu yerlerde ekleyebilirsiniz. O grupla ilgili özel bir işiniz yok ise bu tarz kısaltmalar
oldukça işe yarayacaktır. Gerekirse girdiğiniz kısa isimlendirmenin (kurallara uyması şartı
ile) uzun hallerine dönüştürülmesi de mümkündür. Örneğin heksil grubunun uzun halini
görmek istiyorsanız Tools → Expand Shorthand Formulae komutunu işleterek uzun
hallerini görebilirsiniz. Şimdi, etiket eklemek için gereken adımları anlatarak bu bölümü
sonlandıralım. Etiket bir sübstitüent olarak eklenmelidir. Bunun için istediğiniz atomu
seçebilirsiniz, biz C atomunu seçerek bir CH3 sübstitüenti oluşturduk. Daha sonra, sol
araç çubuğunun alt kısımlarında Edit Atom Label düğmesini tıklatıyoruz ve CH 3 grubunun
üzerine tıklayınca bir pencere açılıyor. Pencere açılınca otomatik olarak metin girme
kısmına geliyoruz. C6H13 yazıyoruz ve program sayıları otomatik olarak alt indis
şeklinde gösteriyor. Ekleme bittikten sonra sol alttaki Insert düğmesini tıklayarak işlemi
bitiriyoruz. Benzer şekilde, bazı bileşikler tek formül şeklinde O veya S atomu içerebilir.
Bu durumda O ve S atomu içeren yapıları ayrı ayrı çizmek yerine X = O, S gibi bir
düşünce ile O veya S atomu bulunan yerlere X yazılabilir. Bunu da aynı yöntemle
yapabiliriz. Denemeyi size bırakıyoruz.
R grupları ekleme
Bazı durumlarda alkil ve aril grupları kısaca R şeklinde gösterilir. Bazı durumlarda da, bir
bileşiğe birden fazla sübstitüent bağlanır ve bunlar birbirinden farklı ise R1, R2, R3
şeklinde gösterilebilir. Her iki işlevi de aynı yerden halledeceğiz. Yukarıda bahsettiğimiz
etiket oluşturma fonksiyonunda olduğu gibi R gruplarının eklenmesinde de yapının
sübstitüentli olarak çizilmesi gerekir, sürükle-bırak yöntemi işe yaramaz. Sübstitüenti
çizdikten sonra Radical Label tuşuna (sol araç çubuğunda alt tarafta, R şeklinde görünen
düğme) basıyoruz. Doğrudan R simgesine ihtiyaç duyuyorsak yapmamız gereken
<6>
oldukça basit, ancak R1 veya R1 veya yalancı atom ilave etmek istiyorsak, düğmenin sağ
alttaki beyaz kısma tıklayarak alternatif görünümlere ulaşabilirsiniz ve uygun olan
seçeneği işaretleyebilirsiniz. ChemSketch'te bir düğmenin sağ altındaki beyaz kısım,
düğmenin daha başka fonksiyonları olduğunu gösteren önemli bir özelliktir. Boş
vaktinizde ChemSketch “dünyasında” yolculuğa çıkarak başka hangi düğmelerde başka
işlevlerin saklı olduğunu görmek sanırız ilginç olacaktır.
Zincir çizim aracı
Zincir şeklinde (özellikle karbon için), bir yapıyı zincir şeklinde göstermeniz gerekirse
zincir çizim aracını kullanabilirsiniz. Bu araç üst araç çubuğunda sol tarafta
bulunmaktadır. Bu aracı kullanmadan önce karbon tuşuna bastığınızdan emin olun,
yoksa elde edeceğiniz sonuç sizi tatmin etmeyebilir (oksijen tuşuna basılı iken 16 atomlu
bir zincir çizdiğinizi düşünün!). Zinciri uzatmak basılı tutup sürüklemek ile olur ve kaç
karbonda olduğunuzu takip etmenizi kolaylaştırmak amacı ile bir sayı görüntülenir. Yine
de biz mecbur kaldığınız haller dışında kısa gösterimi tercih etmeniz konusunda sizi
yüreklendirmek isteriz.
Stereokimyasal bağ ekleme
Bazı bağlar stereokimyasal olarak ifade edilmelidir. Yani “wedge” veya “kama” şeklinde
gösterilmelidir. Bunu eklemek için sübstitüent oluşturulur, uygun kama şekli seçilir (bize
doğru olan koyu renkli kama veya bizden uzakta olan açık renkli kama) ve bağın üzerine
tıklanır. Bağın üzerine tekrar tekrar tıklayarak size en uygun biçimi bulabilirisiniz. Toplam
3-4 olasılık vardır, vazgeçerseniz tıklamaya devam ederek başa dönmek mümkündür.
Yapı düzeltme ve basit eniyileştirme araçları
Yapı düzeltme (clean structure) aracı bağ uzunluklarını ve açılarını en uygun hale
getirmeye yarar. F9 tuşu veya çizim kipinde sağ üstte yer alan düğmesi kullanılarak
seçilmiş bir yapı veya çizilmiş bütün yapılar aynı anda düzeltilebilir. Biz mümkün
mertebe tek bir yapının düzeltilmesinden yanayız, çünkü zaten güzel görünen bir şeklin
bozulma tehlikesine karşı iyi bir önlem olarak düşünüyoruz.
Basit eniyileştirme (optimization) aracı ise CTRL+3 tuşu ile veya yapı düzeltme
düğmesinin yanında bulunan düğme ile çalıştırılır. Yapı düzeltmeden farklı olarak bir
kerede yalnızca bir yapı eniyileştirilebilir. Burada yapılan iş bir algoritma üzerinden
yapının düzeltilmeye çalışılması ve bağ açıları ile uzunluklarının ayarlanmasından
ibarettir. Bu aracı hesapsal kimya modüllerindeki eniyileştirme araçlarıyla bir tutmamak
gerekir. Algoritmasının basit olması nedeniyle küçük organik moleküller için kullanışlı
olsa da molekül büyüdükçe hata oranı artar.
Basit bir örnek olarak klorobenzen örneğini vereceğiz. Klorobenzen molekülündeki kloru
iyice uzatın ve eniyileştirme algoritmasını çalıştırın. Klor atomunun benzen halkasına en
uygun yere konumlandığını ve bağ açısının en uygun duruma ayarlandığını göreceksiniz.
InChi ve SMILES araçları
InChi IUPAC tarafından ortaya konan bir metinsel yapı dönüştürme aracıdır. SMILES ise
InChi'den biraz daha eski ve kanımızca biraz daha sık kullanılan bir başka metinsel yapı
dönüştürme aracıdır.
<7>
Basit olması amacıyla metilamin, piridin ve benzoik asit moleküllerinin InChi ve SMILES
kodlarını yazacağız.
Yeri gelmişken, çizdiğiniz bir yapının InChi kodunu üretmek için Tools → Generate → InChi
for Structure komutunu vermelisiniz. SMILES kodu için ise aynı yerdeki SMILES notation
komutunu işleteceksiniz.
Yapı
InChi kodu
SMILES kodu
metilamin
InChI=1/CH5N/C1-2/h2H2,1H3
CN
piridin
InChI=1/C5H5N/C1-2-4-6-5-3-1/h1-5H
c1ccccn1
benzoik asit InChI=1/C7H6O2/C8-7(9)6-4-2-1-3-5-6/h1-5H,(H,8,9) O=C(O)c1ccccc1
SMILES ve InChI notasyonlarını kullanmanın ikinci kısmı da, bir web sitesinden veya
başka bir kaynaktan bulduğunuz notasyonların formüle çevrilmesidir. ChemSketch bu
konuda da size uzman çözümler sunmaktadır. Yine üç örnek vererek konuyu bitirelim
(örneklerimiz en.wikipedia.org adresinden alınmıştır):
Brusin için InChI dizgesi olarak InChI=1S/C23H26N2O4/c1-27-16-8-14-15(9-17(16)282)25-20(26)10-18-21-13-7-19-23(14,22(21)25)4-5-24(19)11-12(13)3-6-29-18/h3,89,13,18-19,21-22H,4-7,10-11H2,1-2H3/t13-,18-,19-,21-,22-,23+/m0/s1 önerilmiştir. Bu
dizgeyi girdiğimiz zaman elde edilen sonuç şöyledir:
Aynı yapının SMILES dizgesi olan
O=C7N2c1cc(OC)c(OC)cc1[[email protected]@]64[[email protected]@H]2[[email protected]@H]3[[email protected]@H](OC/C=C5\
[[email protected]@H]3C[[email protected]@H]6N(CC4)C5)C7 ifadesi de şu sonucu veriyor:
Bu iki yapı arasında biraz dikkatli bakarsanız önemli bir fark göreceksiniz. SMILES yapısı
çok basit ifadeler kullanmasına rağmen hata yapmaktadır. Dolayısı ile yapıda
stereokimyasal bağlar varsa SMILES yerine InChI notasyonunun kullanılması daha
doğrudur kanaatine vardık.
Peki, bir SMILES veya InChI dizgesini bulduğumuz zaman yapıya nasıl dönüştüreceğiz,
onu anlatalım. Tools → Generate → Structure from InChI veya Structure from SMILES
komutları işletilerek yapılar bir saniyede oluşturulabilir.
<8>
İki kısa örnek yaparak bu konuyu kapatıyoruz. Riboflavin, B2 vitamini olup InChI formülü
şöyledir: InChI=InChI=1S/C17H20N4O6/c1-7-3-9-10(4-8(7)2)21(5-11(23)14(25)12(24)622)15-13(18-9)16(26)20-17(27)19-15/h3-4,11-12,14,22-25H,5-6H2,1-2H3,
(H,20,26,27)/t11-,12+,14-/m0/s1
Bu formüle uygun yapı da şöyle elde edilmektedir:
Yapının SMILES kodu O=C2/N=C\1/N(c3cc(c(cc3/N=C/1C(=O)N2)C)C)C[[email protected]](O)[[email protected]]
(O)[[email protected]](O)CO şeklindedir ve ChemSketch programı ile oluşturulan yapı şöyledir:
PubChem, ChemSpider ve eMolecules araçları
PubChem, ChemSpider ve eMolecules, birbirinden yetenekli üç yapı bulma aracıdır. Yapı
bulmadan kastımız, çizdiğiniz bir yapının çok önemli olan Chemical Abstracts kayıt
numarasını (CAS RN), erime, kaynama noktalarını, zehirliliğini, hangi kimya firmaları
tarafından satıldığını öğrenebilirsiniz. Şimdi örnek molekül olarak isatini (1H-indol-2,3dion) alarak üç araç için ne sonuçlar elde edildiğini görelim. Bu arada, sonuçların
internet tarayıcısında açılması ChemSketch içinde açılmasından daha iyi sonuçlar
vermektedir. PubChem düğmesi veya diğer düğmeler tıklanınca yapının tam olarak mı,
yoksa alt yapılar düşünülerek mi açılması gerektiği sorulacaktır. Yapıdan %100 eminseniz
tam yapıyı seçmeniz daha akıllıca olur. Aksi takdirde alt yapıları da görüntüleyebilirsiniz.
PubChem çok ayrıntılı bilgiler verirken eMolecules maddenin yapısını, molekül ağırlığını
ve sağlayan firmaların isimleri ile katalog numaralarını bildirmektedir. ChemSpider ise
İngiliz Kimya Cemiyetinin (RSC) ürünü olup PubChem'e yakın bilgiler vermektedir. Size
tavsiyemiz, bir arama motorunda ilgilendiğiniz sonucu bulamazsanız diğer motorlarda
şansınızı deneyin ve özellikle CAS RN elde edilmişse Science Finder gibi güçlü literatür
arama motorlarını kullanarak çok sayıda bilgi elde edebilirsiniz.
<9>
Üst menü seçenekleri: Menülerin incelenmesi
Yapı (Structure) kipinde üst menüler şöyle sıralanmaktadır:
File menüsünde sıra ile yeni bir dosya oluşturma, bir dosya açma, dosyayı kapama,
kaydetme, farklı bir isim veya biçimle kaydetme ve açık dosyaların tümünü kaydetme
seçenekleri bulunur. Bunun dışında farklı biçimlere dosya kaydetmek için bizim de sıkça
kullandığımız Export ve Import seçenekleri vardır. Export seçeneği ile daha önce
bahsettiğimiz ScienceFinder için MOL (MDL) biçiminde dosya kaydederek ScienceFinder
içinde çizmek zorunda kalmadan doğrudan doğruya dosyayı gönderebilirsiniz. Import da
başka bir çizim programından ChemSketch içine veri almak için kullanılabilir, ancak
kanımızca InChI ve/veya SMILES (yapının basitliğine göre) daha uygun çözümler sunar.
ChemBasic betikleri bas uzantısına sahiptir ve ChemBasic dili ile kodladığınız küçük
programları işletmenize olanak tanır. Bu konuya burada girmeyeceğiz, ancak
programlamaya hevesli olanların ve en az bir programlama dilini iyi biçimde bilenlerin
anlayabileceği birşey olduğunu söylemekle yetineceğiz. Form düzenleme de ileri düzey
bir konu olup büyük ihtimalle bu seviyede işinize yarayacak birşey değildir, o nedenle
ilgilenenlerin ChemSketch elkitabını okumasını öneririz. Sayfa düzeninde sayfa biçimini
(A4 öneririz), kenar boşluklarını ayarlayabilirsiniz. Yazdırma bir dosya içindeki bütün
sayfaları yazdırma şeklinde olabileceği gibi aralıklı veya tek sayfa yazdırma (Geçerli
Sayfa) şeklinde de olabilir. Yazdırma düzeni seçeneğinde çalışmanızın sayfada nasıl
görüneceğini de görebilirsiniz. Properties ile belge özelliklerini düzenleyebilirsiniz (Yazar,
kurum, kişi, vs). Send komutu ile çalışmayı olduğu gibi (ChemSketch'in dosya biçimi olan
SK2 şeklinde) veya PDF olarak gönderebilirsiniz. Dosya biçimlerini kontrol edebilmeniz
için (File Associations), yani SK2 dosyalarının hangi programla açılacağını kontrol
edebilmeniz için yönetici haklarına sahip olmanız gerekir. Çıkış yapılan komutun altında
son zamanlarda açılan dosyaların listesinin tutulduğu, bize göre çok kullanışlı bir komut
vardır. Burada bugün, dün, son bir hafta, son ay, son yıl şeklinde kategorilere ayrılmış
olan dosyalarınızı görüntüleyebilirsiniz. Bunun dışında, 0, 1, 2 şeklinde en altta
görüntülenen sayılar, o anda açık olan dosyaları temsil etmektedir ve buradan bu
dosyalar arasında geçiş yapabilirsiniz.
<10>
File
Edit
Pages
Tools
Templates
Options
Documents Add-Ons
New
Undo
New
Structure
Properties
Template
Window...
Preferences.. Next
.
Open
Redo
Insert
Clean
Structure
Template
Organizer...
Show Grid
Close
Cut
Change
Order...
Check
Tautomeric
Forms
Save User
Template...
Snap on Grid Close All
Save
Copy
Delete
3D Structure Table of
Optimization Radicals...
Show Palette 1 [dosya adı] Search
ChemSpider
Help
Contents
Next Loaded ChemBasic
Help
Save As
Paste
Rename...
MassSpec
Scissors
Periodic
Table...
Show RSS
Send
Feedback...
Anchor
Save All
Delete
Color...
Show
Aromaticity
Dictionary...
Set Structure
Drawing
Style
Register at I- Exit All
Lab...
Export
Select All
Header and
Footer
Hide
Aromaticity
Add-On
Organizer...
Request
Demo Key...
Import
Insert
Object...
Previous
Expand
Shorthand
Formulae
ChemBasic
Organizer...
Register
Demo
Access...
Visit
ACD/Labs
Web Site...
Run
Edit Object
ChemBasic...
Next
Add Explicit
Hydrogens
Activate
Account...
Bug
Report/Featu
re Request...
Forms
Manager...
First
Remove
Explicit
Hydrogens
Previous
I-Lab
ACD/Labs
Help
Calculate
LogP
Login...
1 3D Viever
(Freeware)
Help Topics
Search
PubChem
Options...
2 C+H NMR
Viewer
Using Help
Search
eMolecules
About ACD/I- 3
Tip of the
Lab...
ChemSketch Day...
(Freeware)
(Loaded)
2 [dosya adı] Search
Options...
Message Box
Preferences..
.
Documents
Setup Style... ACD/Labs
Products...
Bug Report
Settings...
Page Setup...
Last
Bring
Bond(s) to
Front
Print...
Bring
Bond(s) to
Back
Print
Preview...
Auto
Renumbering
Properties
Clear
Numbering
Send
Generate
File
Associations.
..
Search for
Structure...
Exit
Calculate
Recent Files
0
About
ACD/ChemSk
etch
(Freeware)
Edit menüsü altında son yapılan işlemi geri alma ve yineleme olarak sıkça kullandığımız
faydalı araçlar bulunmaktadır. Bunun dışında kesme, yapıştırma, özel yapıştırma ve çok
ilginç olarak tablo yapıştırma öğelerine erişebilirsiniz.
Pages menüsü altında sayfa yönetim araçları bulunuyor. Yeni bir sayfa oluşturmak, sayfa
eklemek, sayfaların sırasını değiştirmek, sayfa silmek, sayfaları yeniden adlandırmak,
sayfaların renklerini ayarlamak, sayfaya üstbilgi ve altbilgi eklemek, sayfalar arasında
dolaşmak (önceki sayfa, sonraki sayfa, ilk sayfa, son sayfa) mümkündür.
Tools menüsünde ise yapı özellikleri, yapıyı düzeltme, tautomerik biçimleri denetleme,
3D yapı eniyileştirmesi, kütle spektrometrede tespit edilebilecek kısımların görünmesi
için “makas” aracı, aromatikliği gösterme, aromatikliği gizleme, kısa biçimi yazılmış
ifadelerin uzun hallerine çevrilmesi, görüntülenmeyen hidrojenleri görüntüleme,
görüntülenen hidrojenleri gizleme seçenekleri bulunmaktadır. Bunların yanı sıra bağları
öne getirmek, bağları arkaya götürmek, atomlara numara vermek, numarayı
temizlemek, çeşitli özellikleri oluşturmak için Generate menüsü, bir yapıyı aramak (bu
özellik yalnızca ticari sürümde geçerlidir), çeşitli özellikleri hesaplamak için Calculate
menüsü bulunmaktadır.
Templates menüsü şablon özelliklerini barındırmaktadır. Şablonları görüntüleme,
şablonları ayarlama, kullanıcı şablonu kaydetme, radikal tablosu, periyodik tablo,
yalnızca ticari sürümde bulunan sözlük özelliklerine ulaşılabilir.
Options menüsünde tercihler, ızgara görünümünü etkinleştirme, ızgaraya yapıştırma,
paleti gösterme, RSS (ACD firmasının haberleri) özelliğini etkinleştirme, yapı çizim
biçimini ayarlama, eklenti biçimini ayarlama, ChemBasic ayarlarını görüntüleme
özellikleri yer almaktadır.
Documents kısmında aynı anda açık birden fazla dosyaya erişimi kolaylaştıran özellikler
bulunmaktadır. Sonraki belge, önceki belge, bütün belgeleri kapatma, dosya adına
numaralardan kısa erişim sağlama özellikleri bu menüde bulunmaktadır.
Add-Ons menüsü eklentileri yöneten menüdür. LogP hesabı yapmak, PubChem dizinini
aramak, eMolecules dizinini aramak, ChemSpider dizinini aramak, arama özelliklerini
incelemek burada yapılabilecek işlemler arasındadır.
I-Lab, ACD-Labs firmasının uzaktan erişim modeline göre oluşturduğu ticari bir hizmettir.
I-Lab hesabı alındıktan sonra internet üzerinden bir bilgisayar kullanarak ACD-Labs
bilgisayarlarına bağlanarak ticari sürümde yer alan özellikleri test edebilir ve
faydalanabilirsiniz. Giriş yapma, seçenekleri inceleme, ACD/I-Lab hakkında bilgi alma,
yardım içeriklerini görüntüleme, geri bildirim yapma, I-Lab hizmetine kayıt olma, Demo
(gösteri) anahtarı talep etme, Demo erişime kayıt olma, hesabı aktifleştirme özelliklerine
buradan erişebilirsiniz.
ACD/Labs menüsü altında ACD/Labs programlarının hangisinin çalışır durumda olduğunu
görüntüleyebilirsiniz. 1 tuşu altında 3D Viewer (belli koşula sahip moleküllerin üç boyutlu
olarak çeşitli gösterim tekniklerine göre görüntülenmesi), 2 tuşu altında C+H NMR
görüntüleyici (yapıdan NMR spektrumu çıkaran bazı programlar bulunsa da, bunların
güvenirliği azdır, ACD/Labs programları içinde böyle bir program mevcut değildir; bu
program sadece kaydedilmiş bir NMR dosyasını görüntülemeye yarar), 3 tuşu altında
ChemSketch (bedava ya da ticari sürüm), bunun altında hafızada yüklü bir sonraki
programa geçme, Anchor özelliği ile ekrana çapalama, Exit All ile hepsinden çıkma ve
Setup Style ile özellik ayarlaması yapılabilir.
Yardım menüsü oldukça geniştir, ancak İngilizce dilinde hazırlanmıştır. Yardım konuları,
<13>
yardım menüsünün kullanılması, günün ipucu, ChemBasic yardımının görüntülenmesi,
ileti kutusunun tercihlerini görüntülemek, belgeleri incelemek, ACD/Labs ürünleri
hakkında bilgi almak, ACD/Labs web sitesini ziyaret etmek, bir hata bildirimi veya özellik
isteğinde bulunmak, hata bildirimi ayarlarını incelemek, ACD/ChemSketch programının
sürüm bilgisini edinmek burada yapabileceğiniz işlemler arasındadır.
Özellik üretme (Generate) yöntemleri
Özellik üretme menüsü
Hesaplama (Calculate) yöntemleri
Yukarıda da kısaca
Çizim (Draw) Kipindeki araçların incelenmesi
<14>

Benzer belgeler