veri tabanı uygulamaları

Yorumlar

Transkript

veri tabanı uygulamaları
Veri Tabanı Uygulamaları
5. ÜNİTE
Veri tabanı Uygulamaları
Üniteye Hazırlık
1. Kişisel verilerin bilgisayar ortamında nasıl saklandığını araştırınız.
2. Ülkemizde devlet kurumları milyonlarca kişinin bilgisini nasıl tutmaktadır? Araştırınız.
3. Okuldaki bilgisayarda bir öğrenci hakkında hangi bilgiler tutulmaktadır? Araştırınız.
5. Veri tabanı programları hangi amaçla kullanılmaktadır? Araştırınız.
141
Bilgi ve İletişim Teknolojisi
A. BAŞLANGIÇ
Konuya Hazırlık
1. MS Access programını bilgisayarımıza nasıl yükleriz? Araştırınız.
2. Günümüzde kullanılan veri tabanı programları hangileridir? Araştırınız.
MS Access bir veri tabanı programıdır. Bir konuyla ilgili çok sayıda verinin tutulmasına, depolanmasına ve belli bir mantık içerisinde gruplara ayrılmasına veri tabanı denir. Veri tabanı programları; bilgisayara verilerin toplanması, toplanan verilere erişimi, istenilen veriler üzerinde değişiklik yapılmasını
ve istenilen verilerin listelenmesini sağlayan bir yapıdır.
1. Veri Tabanıyla İlk Adımlar
a. Veri Tabanı Uygulamasını Açma
Veri tabanı programı MS Access’i açmak için Başlat menüsüne tıklanır, açılan menüden Tüm
Programlar seçeneği seçilir, gelen menüden Microsoft Office seçeneği altında yer alan Microsoft
Office Access programına tıklanır.
Bu işlemler sonrasında karşımıza MS Access program penceresi gelecektir (Resim 5.1).
Başlık Çubuğu
Menü Çubuğu
Veri Tabanı Araç Çubuğu
Görev
Bölmesi
Durum Çubuğu
Resim 5.1: MS Access penceresi
MS Access uygulaması ekranında; Başlık Çubuğu, Menü Çubuğu, Durum Çubuğu ve Görev
Bölmesi alanları bulunmaktadır. Bu ekranda sadece Veri Tabanı Araç Çubuğu standart olarak bulunmaktadır (Resim 5.1).
b. Mevcut Veri Tabanını Açma
MS Access veri tabanı programı yüklendiğinde örnek veri tabanı olan Northwindde bilgisayara
yüklenir. Bu veri tabanı dünya çapında gıda maddesi ihracatı ve ithalatı yapan “Northwind Traders”
adında hayal ürünü bir şirketin satış verilerini içerir. Northwind bizim yapacağımız veri tabanı uygulamaları için örnekler oluşturmaktadır. MS Access’in çalışma mantığını anlamak için kendi verilerinizi
girmeden önce mevcut veri tabanının verileriyle deneme yapabilirsiniz.
142
Veri Tabanı Uygulamaları
Mevcut veri tabanı olan Northwind’i açmak için
aşağıdaki adımları takip edelim:
1.Yardım menüsü altında bulunan Örnek
Veri Tabanları… komutunu seçelim.
2.Örnek Veri Tabanları… komutu altından
Northwind Örnek Veri Tabanı komutuna
tıklayalım (Resim 5.2).
Resim 5.2: Örnek veri tabınını açma
Böylece Northwind örnek
veri tabanı açılmış olacaktır (Resim 5.3).
Açılan veri tabanında; Tablolar, Sorgular, Formlar, Raporlar, Sayfalar, Makrolar ve
Modüller bulunmaktadır.
Bu nesnelerin işlevleri aşağıdaki gibidir:
Tablolar:
Veri
tabanının
ana bileşeni ve bilgilerin tutulduğu yer tablodur. Bir veri tabanın-
Resim 5.3: Northwind örnek veri tabanı penceresi
da ilk olarak tablolar, ardından
tablolar esas alınarak diğer bölümler oluşturulur. Hazırlanan bir veri tabanında birden çok tablo bulunabilir.
Sorgular: Bu bölümde; hazırlanan tablolarda tutulan kayıtlar arasından, belli şartları taşıyanlar görüntülenebilir, bu kayıtlar üzerinde işlem yapılabilir veya bu kayıtlarla yeni bir tablo oluşturulabilir.
Formlar: Formlar hazırlanarak mevcut tablolara bilgiler kolayca girilebilir ve tablolardaki bilgiler
daha anlaşılır bir biçimde görüntülenebilir.
Raporlar: Bu bölüm, tablolardaki bilgileri belirli bir düzende kâğıda dökebilmek için kullanılır.
Sayfalar: Veri erişim sayfasında, veri tabanında kaydedilen veriler görüntülenebilir, istenen verilere
ekleme yapılabilir, düzenlenebilir veya işlenebilir. Sayfa aynı zamanda Excel gibi başka kaynaklardan
gelen verileri de kapsayabilir.
Makrolar: Veri tabanında birden fazla işlemi bir defada yapmak için tasarlanan küçük program
parçalarıdır.
Modüller: Access’te başka küçük program parçacıkları hazırlamak da mümkündür. Bu bölümde
Visual Basic programı kullanılarak program parçaları da yazılabilir.
c. Veri Tabanı İçindeki Kaydı Değiştirme
MS Access veri tabanı programında oluşturduğumuz bir tablodan verileri değiştirmek için aşağıdaki adımları takip edelim:
143
Bilgi ve İletişim Teknolojisi
1. Açık olan mevcut Northwind
veri tabanı dosyasının Nesneler bölümünden Tablolar bölümüne tıklayalım (Resim 5.3).
2. Ekrana gelen hazırlanmış tablolar listesinden Categories’e
çift tıklayalım. Categories tablosu açılacaktır.
Resim 5.4: Kayıt değiştirme
3. Category Name sütunundan “Beverages”’ metnini seçelim ve yerine “İçecek” metnini yazalım
(Resim 5.4)
Bir kayıt üzerinde değişiklik yapıldıktan sonra diğer kayıtlara geçildiğinde son yapılan değişiklik
otomatik kaydedilir.
Çalışma Etkinliği
Category Name sütunundan “Confections”’ metni yerine “Tekstil” metnini yazınız.
ç. Kaydetme
Açık olan veri tabanı üzerinde değişiklik
yapıldığında çalışmaların kaydedilmesi gerekir. Kayıt işlemi için aşağıdaki seçeneklerden
biri kullanılır:
1. Dosya menüsünden Kaydet komutunu kullanmak.
Resim 5.5: Kaydetme penceresi
2. Klavyeden CTRL+S tuşlarına birlikte basmak.
3. Araç çubuğu üzerinde bulunan Kaydet (
)simgesine tıklamak.
Yukarıdaki seçeneklerden herhangi biri seçildiğinde karşımıza Resim 5.5’teki Farklı Kaydet penceresi açılır. Buradan bir tablo ismi verilerek Tamam düğmesine tıklanır.
d. Veri Tabanını Kapatma
Üzerinde çalıştığımız veri tabanını kapatmak için aşağıdaki seçeneklerden biri kullanılır:
1. Dosya menüsünden Çıkış komutunu vermek.
2. MS Access penceresinin sağ üst köşesinde bulunan kapat (
) simgesine tıklamak.
3. Klavyeden ALT + F4 tuşlarına birlikte basmak.
e. Yardım Fonksiyonlarını Kullanma
MS Access veri tabanı uygulamasında bir konuyla ilgili yardım almak için aşağıdaki adımları takip
edelim:
1. Yardım menüsünü açalım.
144
Veri Tabanı Uygulamaları
2. Açılan menüden Microsoft Office Acces Yardımı komutunu tıklayalım.
3. Ekranın sağ tarafına Yardım penceresi açılır (Resim 5.6).
4.Ara kutucuğuna aramak istediğimiz bir veya birden fazla anahtar sözcüğü yazalım ve Aramayı Başlat (
) simgesine tıklayalım. Arama
sonucunda bulunan konular altta listelenecektir.
Ek Bilgi
Access Yardım penceresini açmak için ayrıca klavyeden F1 tuşu
kullanılabilir.
Yardım penceresini açmanın diğer bir yolu da Veri Tabanı Araç
Çubuğu üzerinde bulunan Microsoft Office Access Yardımı (
) simResim 5.6: Access yardımı görev bölmesi
gesine tıklamaktır.
Çalışma Etkinliği
Access Yardım penceresinde “Tablolar” metnini aratarak tablolar hakkında bilgi edininiz.
2. Temel Ayarları Yapma
a. Veri Tabanı Uygulamasının Sayfa Görünümünü Değiştirme
MS Access veri tabanında nesnelerin sayfa görünümünü değiştirmek için ilk önce hazırlanmış nesne açılır ve Görünüm menüsünden istenilen görünüm tipi seçilerek değişiklik uygulanmış olur.
b. Araç Çubuğu Özelliklerini Değiştirme
MS Access uygulaması ekranında bulunan araç çubuklarını kaldırmak veya yenilerini
eklemek için aşağıdaki adımları takip edelim:
1. Görünüm menüsündeki Araç Çubukları altından Özelleştir komutunu seçelim (Resim 5.7).
2. Açılan Özelleştir penceresinden Araç
Çubukları sekmesine tıklayalım ve burada bulunan listedeki araç çubuklarını
işaretleyerek aktif hâle gelmelerini sağlayalım.
Resim 5.7: Araç çubukları penceresi
145
Bilgi ve İletişim Teknolojisi
Değerlendirme Soruları
1. Bir konuyla ilgili çok sayıda verinin tutulmasına ve depolanmasına ne denir?
A) Tablolama B) Veri Tabanı
D) Verileme
E) İnternet
C) Bilgi İşlem 2. MS Access veri tabanı programı kurulduğunda bilgisayara yüklenen örnek veri tabanı
ismi nedir?
A) Northwind
B) Access
D) Traders
E) WordAccess
C) Örnek veri
3. Veri tabanında birden fazla işlemi bir defada yerine getirmek için hazırlanan ve kullanılan küçük program parçalarına ne ad verilir?
A) Tablo
B) Rapor
D) Sorgu
E) Makro
C) Sayfa
4. MS Access veri tabanında nesnelerin sayfa görünümünü değiştirmek için kullanılan
menü aşağıdakilerden hangisidir?
A) Biçim
B) Dosya
D) Pencere
E) Düzen
C) Görünüm
5. Access Yardım penceresini açmak için kullanılan klavye tuşu aşağıdakilerden hangisidir?
146
A) F1
B) F2
C) F3
D) F4
E) F5
Veri Tabanı Uygulamaları
B. BİR VERİ TABANI YARATMA
Konuya Hazırlık
1. İnsanlar hafızalarında ne gibi bilgileri gruplandırarak tutmaktadır? Tartışınız.
2. Veri tabanlarına bilgi kaydetmenin bir sınırı var mıdır? Araştırınız.
MS Access’te veri tabanı oluşturmadan önce mutlaka iyi bir planlamaya ihtiyaç vardır. Oluşturulacak veri tabanını nerelerde, kimlerin, hangi amaçlar için kullanacağı ve içerisinde hangi nesnelerin
olması gerektiği açıkça belirtilmelidir. Ayrıca veri tabanını hazırlayan kişinin bu kıstasları çok iyi analiz
etmesi ve verileri ona göre hazırlaması gerekmektedir.
1. Temel İşlemler
a. Veri Tabanını Planlama ve Tasarlama
İyi bir veri tabanı oluşturmanın en önemli adımı planlama ve tasarlamadır. Veri tabanı tasarlamada,
tasarımın amacı ve ne için kullanılması gerektiği belirlenmelidir.
Tasarım aşamasında aşağıdaki kıstaslar dikkate alınmalıdır:
1. Hazırlayacağınız veri tabanını kimler kullanacaksa onlarla konuşunuz.
2. Veri tabanının hangi raporları oluşturmasını istiyorsanız taslağını çiziniz.
3. Veri tabanında verilerinizi kaydetmek için kullandığınız formları bir araya getiriniz.
4. MS Access’te Tabloları, sorguları ve diğer nesneleri oluşturmadan önce tasarımınızı kâğıt üzerinde oluşturmak ve üzerinde çalışmak iyi bir fikirdir. Ayrıca tasarlamakta olduğunuz veri tabanına benzeyen ve iyi tasarlanmış veri tabanlarını da inceleyebilirsiniz.
5. İyi tasarımlanmış bir veri tabanı genellikle gerek duyduğunuz bilgileri gösteren farklı türde sorgular içerir.
6. Tasarımda diğer bir adım da veri tabanınızda gerek duyduğunuz alanları belirlemektir. Veri
tabanında her alan belirli bir konuyla ilgili bir olguyu içerir. Örneğin, ürünlerinizle ilgili hangi olguları bulundurmak istersiniz? Düşünün: Ürünün adı, üretim tarihi, üretim yeri, içindekiler ve son
kullanma tarihi. Belirlediğiniz bu olguların her biri için ayrı ayrı alan oluşturmanız gerekecektir.
7. Ayrıca oluşturacağınız veri tabanında ana nesne olan tabloları belirlemelisiniz. Her tablo bir
konu hakkında bilgi içermelidir. Daha önce belirlediğiniz olgulardan yararlanarak alan listenizi
oluşturunuz. Bu liste ihtiyaç duyduğunuz tablolara ilişkin ipuçları sağlar.
Tasarım aşaması tamamlandığında öncelikle MS Access programında oluşturacağımız veri tabanlarını kaydetmek için Belgelerim klasörü içindeki “MS Office Uygulamalarım” klasörünün içerisine
“MS Access Uygulamalarım” adlı bir klasör oluşturunuz. Ardından aşağıdaki adımları izleyerek veri
tabanı oluşturabilirsiniz:
147
Bilgi ve İletişim Teknolojisi
1. Dosya menüsünden Yeni seçeneğini tıklayınız. Yeni Dosya penceresi görev bölmesinde açılacaktır.
2. Yeni Dosya penceresinden Boş veri tabanı seçeneğini seçiniz.
3. Ekrana Yeni Veri Tabanı Dosyası penceresi gelecektir (Resim 5.8).
4. Kayıt Yeri olarak daha önce oluşturulan MS Access Uygulamalarım klasörünü seçiniz.
5. Dosya adı bölümüne Öğrenci İşleri ismini giriniz.
Resim 5.8: Yeni veri tabanı dosyasının kaydı penceresi
6. Oluştur düğmesine tıkladığınızda tablo belirtilen konumda oluşturulur.
7. Bu işlemler sonrasında ekrana Öğrenci İşleri veri tabanı dosyasının açılmış olduğu görülür
(Resim 5.9).
Resim 5.9: Öğrenci işleri veri tabanı penceresi
148
Veri Tabanı Uygulamaları
b. Tablo Oluşturma
Hazırladığımız veri tabanına ana bileşen olan
tablo oluşturmak için aşağıdaki adımları takip edelim:
1. Açık olan “Öğrenci İşleri” Veri Tabanı penceresinde Nesneler bölümünden Tabloları
seçelim (Resim 5.9).
2. Sağ taraftaki seçeneklerden herhangi birisini seçelim.
Açılan penceredeki (Resim 5.10) tabloda ilk sütuna alan adları tanımlanır, ikinci sütuna alanın veri
Resim 5.10: Tasarım görünümünde tablo penceresi
türü belirtilir. Tanım bölümü ise o alanla ilgili açıklama satırıdır.
Aşağıda tabloda veri türleri ve açıklamaları verilmiştir:
VERİ
TÜRLERİ
Metin
Not
AÇIKLAMA
Alfabetik ve sayısal türde her türlü bilgi veya işlem gerektirmeyen bilgilerin girilebildiği alan
türüdür. Bu alan maksimum 255 karakter bilgi alır.
Bir tablo alanı için metin türünün uzunluğu yetmiyorsa not türü seçilebilir. Bu tür alanlara 65535
karaktere kadar bilgi girilebilir.
Üzerinde işlem yapılabilecek sayısal verilerin girilebileceği alan türüdür. Alan boyutunu belirlerken aşağıdaki boyut türleri seçilebilir
1. Bayt : 0 ile 255 arasında değer alabilir. 1 Bayt yer tutar.
Sayı
2. Tamsayı : -32768 ile 32767 arasında değer alabilir. 2 Bayt yer tutar.
3. Uzun tamsayı : -2 147 483 648 ile 2 147 483 647 arasında değer alabilir. 4 Bayt yer tutar.
4. Tek ve Çift : Çok büyük sayılar ve ondalık kesirler için kullanılır. 15 basamak sayıyı tutar,
üstünü ise 10 üssü olarak yazar. 4-8 Bayt yer tutar.
5. Ondalık Sayı : 28 basamağa kadar sayı tutar. 12 Bayt yer tutar.
Tarih/Saat
Para Birimi
Otomatik
Sayı
Evet/Hayır
Tarih ve saat türündeki bilgilerin girilmesi için kullanılır.
Parasal değerler için tanımlanır. Bu alanda 15 basamak tamsayı, virgülden sonra da 4 basamak bilgi tutulabilir.
Bu bilgi alandaki sayı değeri girilen her yeni kaydın numarası otomatik olarak tutulur.
Bu bilgi alanı iki sonuçlu bilgiler için kullanılır. Evet/Hayır, Açık/Kapalı, Doğru/Yanlış gibi veriler
tutulur.
Köprü
İnternet adresi gibi bir yere bağlantı kurmak için bu veri türü kullanılır. Bu alana girilen veriye
tıklanırsa yazılı olan İnternet adresine bağlantı kurulur.
OLE Nesnesi
Resim, ses, film gibi nesnelerin veri tabanına eklenmesini sağlar.
149
Bilgi ve İletişim Teknolojisi
Ek Bilgi
Tanım sütununa alanla ilgili açıklayıcı bilgi yazılabilir. Ancak bu sütuna herhangi bir bilgi
girme zorunluluğu yoktur.
Çalışma Etkinliği
Aşağıdaki gibi örnek bir tablo oluşturmaya çalışınız.
1. Tasarım görünümündeki tabloda Alan Adı sütununu tıklayınız ve ilk alan için “Sıra Nu.”
metnini yazınız. Bilgisayar otomatik olarak Veri Türü sütununa varsayılanı Metin yapar.
Siz Veri Türü’nü Otomatik Sayı olarak değiştiriniz.
2. Diğer alanları da Resim 5.11’deki gibi doldurunuz.
Resim 5.11: Tablo tasarım görünümü
3. Tablo oluşturma işlemini tamamladıktan sonra tasarım penceresini kapatınız.
4. Kapatırken tablo üzerinde yaptığınız değişiklikleri kaydetmek isteyip istemediğiniz sorulacaktır. Evet diyerek değişiklikleri kaydediniz.
5. Daha sonra ilk defa oluşturduğunuz bu tablonun isminin ne
olacağını soran bir pencere gelir
(Resim 5.12). Herhangi bir isim
vererek Tamam düğmesine tıkladığınızda tablo veri tabanınıza
eklenecektir.
Resim 5.12: Tablo kaydı farklı kaydet penceresi
tıklanabilir.
c. Tablo İçinde Hareket Etme
Tablo içinde hareket etmek için herhangi bir hücre tıklanabilir veya yön tuşları kullanılarak hücreler
arasında hareket edilebilir. Aynı kayıttaki alanlar arasında hareket etmek için Tab tuşu kullanılabilir.
Ek Bilgi
Bir hücreye girilen bilgi içerisinde home ve end tuşları kullanılarak başa veya sona gidilebilir. Veri tabanı penceresini öne getirmek için F11 tuşu kullanılır.
150
Veri Tabanı Uygulamaları
ç. Tabloya Veri Girme
Veri tabanı penceresi açıkken Tablolar nesnesinden oluşturduğumuz “ÖĞRENCİ BİLGİLERİ” tablosunu seçelim. Aç düğmesine tıklayarak tablonun açılmasını sağlayalım.
Açılan Tabloda her satır ayrı bir kayıt tutar. Tablomuza yeni kayıt eklemek için tablonun en altında
bulunan boş satır kullanılır. Tablomuzdaki boş satıra yeni kayıt girilmeye başlar başlamaz bu satırın bir
altına yine boş bir satır oluşturulduğunu görürüz. Tablo alanlarına bilgi girildikten sonra Enter tuşuna
basılarak bir sonraki alana geçilebilir.
Siz de tablonuza Resim 5.13’teki gibi örnek bilgiler giriniz.
Resim 5.13: Öğrenci bilgileri tablosu
Tabloya bilgi girişi sırasında bazı sütunların gizlenmesi istenilebilir. Bunun için aşağıdaki adımları
takip edelim:
1. Biçim menüsünden Sütunları Göster seçeneğini
seçelim (Resim 5.14).
2. Buradan gizlemek istediğimiz alanın işaretini kaldırarak Kapat düğmesine tıklayalım:
Çalışma Etkinliği
“ÖĞRENCİ BİLGİLERİ” tablosunda Doğum
Tarihi alanını gizleyiniz ve daha sonra tekrar
gösteriniz.
Resim 5.14: Sütunları göster penceresi
2. Anahtarları Tanımlama
a. Birincil Anahtarı Tanımlama
Birincil anahtar, işlemlerin hızını artırmak ve tabloyu diğer tablolardaki yabancı anahtarlarla ilişkilendirmek için kullanılır. Birincil anahtar olarak tanımlanacak alana girilen veri, tabloda o alandaki her
kayıttan farklı olmalıdır. Örneğin, Cep telefonu, T.C. Kimlik Nu., Müşteri Nu., Sipariş Nu. gibi. Tabloda bir birincil anahtar tanımlamak için aşağıdaki adımları takip edelim:
1. Daha önce oluşturduğumuz “Öğrenci İşleri” veri tabanı dosyasını açalım.
2. Tablolar nesnesine tıklayarak “Öğrenci Bilgileri” tablosunu seçelim ve Tasarla düğmesine
tıklayalım. Tablomuz tasarım görünümünde açılacaktır.
3. Tablomuzun alanlarından benzersiz olan ve veri girilebilecek alan sadece “Numarası” olduğundan birincil anahtar olarak tanımlayabiliriz.
151
Bilgi ve İletişim Teknolojisi
4. “Numarası” alanı üzerinde sağa tıklayalım ve açılan menüden Birincil
Anahtarı seçelim (Resim 5.15).
5. Dosya menüsünden Kaydet komutuna tıkladığımızda tablo birincil anahtar
tanımlanmış olarak kaydedilecektir.
b. İndeks Oluşturma
Resim 5.15: Öğrenci bilgileri tablosu
MC Access’te bir veri tabanı tablosundaki belirli bilgiye hızlı erişim sağlamak için Dizin kullanılabilir.
Dizin bir veri tabanı tablosundaki bir veya daha fazla sütunun değerlerini sıralayan bir yapıdır. Örneğin,
ÖĞRENCİ BİLGİLERİ tablosunun “SOYADI” sütunu. Belirli bir eleman soyadına göre aranıyorsa dizin,
tablodaki tüm satırları aramaya göre daha hızlı bir şekilde bilgi alınmasına yardım eder. Dizin oluşturmak için aşağıdaki adımları takip edelim:
1. ÖĞRENCİ BİLGİLERİ tablosunu Tasarım görünümünde açalım.
2.Görünüm menüsünden Dizinler seçeneğine tıklayarak Dizinler penceresinin
açılmasını sağlayalım.
3. Dizinler penceresini Resim 5.16’daki
gibi dolduralım.
Resim 5.16: Öğrenci bilgileri penceresi
4. Bu işlemlerden sonra penceremizi kapatalım.
Ek Bilgi
Dizin oluşturmak için tablomuz tasarım görünümünden açıkken Araç çubuğunda bulunan
Dizinler (
) simgesini tıklayabiliriz.
Çalışma Etkinliği
ÖĞRENCİ İŞLERİ tablosunda, NUMARASI alanını azalan olarak belirleyiniz.
3. Tablo Tasarımı
a. Tablo Özelliklerini Değiştirme
Daha önce oluşturulan ÖĞRENCİ BİLGİLERİ tablosunun özelliklerini değiştirmek için aşağıdaki
adımları takip edelim:
1. Doğum Tarihi alanı üzerinde farenin sağ tuşuna tıklayalım ve açılan menüden Satır Ekle’yi
seçelim.
2. Yeni açılan satıra “ADRES” adını girelim ve veri türünü Metin olarak ayarlayalım.
152
Veri Tabanı Uygulamaları
3. Böylece yeni bir kayıt alanı oluşturmuş oluruz.
4. ADRES alanını fare yardımıyla en alta alalım.
5. Böylece tablomuz Resim 5.17’deki tasarım
görünümünü alır.
b. Alan Özelliklerini Değiştirme
ÖĞRENCİ BİLGİLERİ tablosunun alan özellik-
Resim 5.17: Tabloda değişiklik
leri üzerinde değişiklik yapabiliriz. Bunun için aşağıdaki adımları takip edelim:
1. Öncelikle tablomuzu tasarım görünümünde açalım.
2. “Numarası” alanı için Alan Boyutu bölümüne Tamsayı, Gerekli bölümünü ise Evet olarak
belirleyelim (Resim 5.18).
3. “Adı” alanı için Alan boyutu “15”, Giriş Maskesine on beş tane yan yana “?” karakteri koyalım. Böylece bu alana sadece alfabetik değer girilebilir. Gerekli bölümünü ise Evet olarak seçelim (Resim 5.19).
4. Soyadı alanı özelliklerini Adı alanıyla aynı yapalım.
5. Tablomuzu kaydedelim. Böylece tablomuzun alan özelliklerini değiştirmiş olduk.
Resim 5.18: Adı alanı özellikleri
Resim 5.19: Numarası alanı özellikleri
4. Veri Tabanını Güncelleme
a. Tablodaki Verileri Değiştirme
Tablodaki bir veriyi değiştirmek için aşağıdaki adımları takip edelim:
1. Veri tabanı penceresi açıkken Tablolar nesnesinden oluşturduğumuz ÖĞRENCİ BİLGİLERİ
tablosuna çift tıklayarak tablomuzun açılmasını sağlayalım.
153
Bilgi ve İletişim Teknolojisi
2. Sıra Nu. “3“ olan kaydın “Adı” alanındaki “Mustafa” verisine tıklayalım ve “Mert Mustafa” şeklinde değiştirelim (Resim 5.20).
3. Enter tuşuna basarak değişikliğin aktif olmasını sağlayalım.
Resim 5.20: Tablodan veri değiştirme
b. Tablodaki Verileri Silme
Açık olan “ÖĞRENCİ BİLGİLERİ” tablosu üzerindeki bir veriyi silmek için aşağıdaki adımları takip
edelim:
1. Sıra Nu. “2“ olan kaydın “Doğum Tarihi” alanında bulunan “02.05.1993” verisini fare yardımıyla
seçelim.
2. Klavyeden Delete tuşuna basalım. Böylece kaydımızın bu verisi silinecektir (Resim 5.20).
c. Veri Tabanına Kayıt Ekleme
Tabloya yeni bir kayıt eklemek için aşağıdaki adımları takip edelim:
1. “ÖĞRENCİ BİLGİLERİ” tablosunu aktif hâle getirelim.
2. Ekle menüsünden Yeni Kayıt seçeneğine tıklayalım.
3. İlk alanda Resim 5.21’deki yeni verileri yazalım, ardından sonraki alana gitmek için klavyeden
ENTER veya TAB (sekme) tuşuna basalım.
Resim 5.21: Kayıt ekleme
4. Her alandaki veri girişini tamamladıktan sonra Dosya menüsünden Kaydet seçeneğine tıklayarak kaydedilmesini sağlayalım.
Ek Bilgi
• Tabloyu kaydetmek için Tablo Veri Sayfası araç çubuğu üzerinde bulunan Kaydet (
simgesine tıklanır.
• Veri girerken bir yanlışlık yapılmış ise Geri Al (
) simgesine tıklanarak işlem geri alına-
bilir. Bulunulan alanda yapılan değişiklikleri iptal etmek için klavyeden ESC tuşuna basılır.
154
)
Veri Tabanı Uygulamaları
ç. Veri Tabanından Kayıt Silme
Mevcut veri tabanı tablomuzdaki Sıra Nu. “2” olan kaydı silmek için aşağıdaki adımları takip edelim:
1. ÖĞRENCİ BİLGİLERİ tablosunu aktif hâle getirelim.
2. Sıra Nu. “2” olan kaydın en solundaki kutucukta iken farenin sağ tuşuna tıklayıp açılan menüden Kayıt Sil seçeneğini tıklayalım (Resim 5.22).
3. Açılan pencerede bu kaydı silmek isteyip istemediğimiz
sorulacaktır. Evet düğmesine tıklayarak işlemi onaylayalım.
Resim 5.22: Kayıt silme
Ek Bilgi
Kayıt silmek için silmek istenilen kayıt üzerinde iken Delete tuşuna basılır veya araç çubuğu üzerinde bulunan Kayıt Sil (
) simgesine tıklanır.
Değerlendirme Soruları
1. Veri tabanı ana bileşenlerinden biri aşağıdakilerden hangisidir?
A) Sorgu
B) Sayfa
D) Tablo
E) Modül
C) Form
2. Tablomuzdaki alanların hangi veri türlerini içerebileceğini belirleyen özellik aşağıdakilerden hangisidir?
A) Veri düzeni
B) Veri türü
D) Veri biçimi
E) Veri yapısı
C) Veri çeşidi
3. Aşağıdaki veri türlerinden hangisi, bilgi alanına iki sonuçlu veriler girmek için kullanılır?
A) Metin
B) Köprü
C) OLE
D) Not
E) Evet/Hayır
4. Aşağıdakilerden hangisi Alan Özellikleri iletişim kutusunda alana belirtilen koşullara
göre veri girmek için kullanılır?
A) Geçerlilik Kuralı
B) Biçim
D) Gerekli
E) Sıralı
C) Varsayılan Değer
5. Tablo içinde aynı kayıttaki alanlar arasında hareket etmek için hangi tuş kullanılır?
A) Alt
B) Tab
C) Ctrl
D) Enter
E) End
155
Bilgi ve İletişim Teknolojisi
C. FORMLARIN KULLANIMI
Konuya Hazırlık
1. Bir işe başvuran kişiden form doldurmasını istemenin faydaları nelerdir? Tartışınız.
2. Sınıflarda oturma planı yapılmasının amacı nedir? Tartışınız.
MS Access veri tabanı programında Form nesnesi, özellikle veri tabanına kolay bir şekilde veri
girilmesi veya verilerin daha anlaşılır bir şekilde görüntülenmesi için kullanılır. Oluşturulan tablo açıldığında aynı anda birçok kayıt görülebilir. Formda birçok kayıt yerine tek bir kayıt ve o kayda ait veriler
bir ekranda belirli bir düzen içerisinde görüntülenir. Form ekranı kullanılarak tabloya bilgi girilebilir veya
değişiklik yapılabilir.
1. Form Oluşturma
a. Basit Bir Form Oluşturma
Daha önce oluşturduğumuz “Öğrenci İşleri” veri tabanı dosyasına bir form oluşturmak için aşağıdaki adımları takip edelim:
1. Öncelikle Öğrenci İşleri veri tabanı dosyasını açalım.
2. Veri tabanı penceresinde Nesneler bölümünden Formlar seçeneğine tıklayalım.
3. Gelen seçeneklerden Sihirbazı Kullanarak Form Oluştur seçeneğini seçelim.
Karşımıza Resim 5.23’teki Form sihirbazı penceresi gelecektir. Bu pencerede formumuzda hangi
tablolardan, hangi verilerin yer alacağını belirleriz. Birçok tablo veya sorgudan seçim yapabiliriz. İlk
önce Tablolar ve Sorgular’dan hangi tablodan veri alınacağı belirlenir ve daha sonra bu tablonun
alan isimleri Kullanılabilir Alanlar bölümünde görülür. Bu alanlardan kullanılmak istenen seçilir ve Taşı
) simgesine tıklanarak Seçili Alanlar bölümüne alınır. Tüm alanlar alınmak istenirse Tümünü
(
Taşı (
) simgesine tıklanır.
4. Tablolar ve sorgular bölümünden
ÖĞRENCİ BİLGİLERİ tablosunu
seçelim.
5. Kullanılabilir Alanlar bölümünden tüm alan isimlerini Tümünü
Taşı (
) simgesine tıklayarak
Seçili Alanlar bölümüne aktaralım ve İleri düğmesine tıklayalım.
Resim 5.23: Form sihirbazı 1. adım penceresi
156
Veri Tabanı Uygulamaları
Karşımıza çıkan Resim 5.24’teki pencerede
bizden formumuza bir yerleşim düzeni seçmemiz
istenmektedir.
1. Sütunlu seçeneğini seçelim ve İleri düğmesine tıklayalım.
2. Erkana gelen pencereden forma hangi stili
uygulamak istediğimizi belirleyelim (Resim
5.25).
Resim 5.24: Form sihirbazı 2. adım penceresi
1. Uluslararası stilini seçelim ve İleri düğmesine tıklayalım.
2. Son aşamada Resim 5.26’daki pencerede
formumuz için başlık olarak “ÖĞRENCİ
FORMU” metnini yazalım ve Son düğmesine tıklayalım.
Resim 5.25: Form sihirbazı 3. adım penceresi
Resim 5.26: Form sihirbazı 4. adım penceresi
Oluşturduğumuz form, ekranımızda görüntülenecektir (Resim 5.27).
Resim 5.27: Öğrenci formu penceresi
157
Bilgi ve İletişim Teknolojisi
b. Formları Kullanarak Veri Tabanına Bilgi Girme
Form kullanarak veri tabanına bilgi girmek için aşağıdaki adımları takip edelim:
1. “Öğrenci İşleri” veri tabanı dosyasını açalım.
2. Veri tabanı penceresinde Nesneler bölümünden Formlara tıklayalım.
3. Açılan pencerede daha önce oluşturduğumuz
“ÖĞRENCİ FORMU” seçeneğine çift tıklayarak
formumuzun açılmasını sağlayalım.
4. Yeni kayıt eklemek için Yeni Kayıt (
) simgesine tıklayalım. Karşımıza böylece boş bir
form penceresi açılacaktır.
5. Bu pencereye Resim 5.28’deki verileri girelim.
Resim 5.28: Yeni kayıt ekleme penceresi
6. Dosya menüsünden Kaydet seçeneğine tıklayarak kayıt işlemini tamamlayalım.
2. Form Görüntüsünü Değiştirme
Hazırlanan formların görüntüsünü değiştirmek için formun tasarım görünümünde açılması gerekir.
Bu işlem için aşağıdaki adımları takip edelim:
1. “Öğrenci İşleri” veri tabanını dosyasını açalım.
2. Nesneler bölümünden Formlar nesnesine tıklayalım ve “ÖĞRENCİ FORMU” nu Tasarım ekranında açalım.
3. Görüntü değişiklerini yapmak için daha önce hazırladığımız formumuz tasarım görünümünde
açılacaktır.
4. Değişikliklerimizi açılan bu form üzerinde yapalım ve kaydederek işlemi tamamlayalım.
a. Metni Biçimleme
Tasarım görünümünde açılmış formda verilerin metin biçimini değiştirmek için aşağıdaki adımları
takip edelim:
1. “Sıra Nu.” alan ismini fare yardımıyla seçelim.
2. Biçimlendirme araç çubuğundan Yazı Tipini “Tahoma”, Yazı Tipi Boyutunu “10”, “Kalın”,
Yazı Tipi Rengini “Yeşil” olarak belirleyelim.
3. Bir önceki adımı her alan ismi için tek tek uygulayalım ve son aşamada formumuzu kaydedelim.
Çalışma Etkinliği
Formdaki alan isimlerinin Yazı Tipini “Arial”, Yazı Tipi Boyutunu “12”, “Kalın”, Yazı Tipi
Rengini de “Mavi” olarak değiştiriniz.
158
Veri Tabanı Uygulamaları
b. Arka Plan Renklerini Değiştirme
Form Tasarımında arka plan rengini değiştirmek için aşağıdaki adımları takip edelim:
1. Alanlara veri girişi için kullanılan metin
kutularından “Sıra Nu.” alan ismini seçelim.
2. Biçimlendirme araç çubuğundan Dolgu/Arka Plan Rengi olarak “Açık Sarı”
rengini seçelim.
3. Bir önceki adımı her veri girişi metin kutusu için tek tek uygulayalım.
4. Tasarım görünümümüz Resim 5.29’daki
gibi olacaktır. Bütün bu değişiklikler
sonrasında formumuzu kaydedelim.
Resim 5.29: Form görünümünü değiştime
c. Şekil ya da Grafik Dosyası Ekleme
Forma şekil ya da grafik dosyası eklemek
için aşağıdaki adımları takip edelim:
1. Öncelikle “ÖĞRENCİ FORMU” nu tasarım görünümünde açalım.
2. Ekle menüsünden Resim seçeneğine
tıklayalım.
3. Gelen Resim Ekle penceresinde bilgisayarımızdaki mevcut resimlerden birini
seçelim ve Tamam düğmesine tıklayalım.
Resim 5.30: Forma şekil ya da grafik dosyası ekleme
4. Tasarım ekranına gelen resmin kenarlarında bulunan noktalardan tutarak uygun boyuta getirelim ve resmi istediğimiz bir konuma yerleştirelim.
5. Tasarım görünümümüz Resim 5.30’daki gibi olacaktır. Son olarak formumuzu kaydedelim ve
işlemimizi tamamlayalım.
Çalışma Etkinliği
Formunuzun alt bölümüne bir çiçek resmi yerleştiriniz.
ç. Nesnelerin Sıralanışını Değiştirme
Formumuza ait her bir nesnenin yerini değiştirmek mümkündür. Bunun için Tasarım görünümünde
açık olan formdaki mevcut nesnelerden birini tıklayarak istediğimiz yere sürükleyebiliriz. Böylece tüm
nesnelerimizi istediğimiz konumda ekranda düzenleyebiliriz.
159
Bilgi ve İletişim Teknolojisi
Değerlendirme Soruları
1. Veri tabanına kolay bir şekilde veri girilmesini veya görüntülenmesini sağlayan nesne
aşağıdakilerden hangisidir?
A) Tablo
B) Sorgu
D) Rapor
E) Makro
2. Oluşturduğumuz formlarda bulunan
C) Form
simgesinin görevi aşağıdakilerden hangisidir?
A) Son Kayıt
B) İlk Kayıt
D) Bir Sonraki Kayıt
E) Kayıt Sil
C) Yeni Kayıt
3. Tasarım görünümünde açık olan formdaki değişiklikleri kaydetmek için aşağıdaki menülerden hangisi kullanılır?
A) Dosya
D) Düzen
D) Ekle
E) Araçlar
C) Biçim
4. Formumuza şekil ya da grafik dosyası eklemek için aşağıdaki menülerden hangisi kullanılır?
A) Dosya
B) Düzen
D) Ekle
E) Araçlar
C) Biçim
5. Tasarım görünümünde formumuzda bulunan verilerin metin biçimini değiştirmek için
hangi araç çubuğu kullanılır?
160
A) Standart B) Veri tabanı
D) Düzen
E) Metin Biçimi
C) Biçimlendirme
Veri Tabanı Uygulamaları
Ç. BİLGİYE ERİŞİM
Konuya Hazırlık
1. Kütüphanelerde araştırma yaparken aradığınız bir kitabı bulmak için hangi yöntemlere
başvurursunuz?
2. “Verileri filtreleme” ifadesi size ne çağrıştırıyor? Açıklayınız.
Oluşturduğumuz veri tabanı dosyasında, birden çok tablo üzerinde belirlediğimiz kriterlere uygun
kayıtlara ulaşmak isteyebiliriz. Bizim tam olarak belirlediğimiz koşulları karşılayan verileri bulmak ve
almak için bir Sorgu oluştururuz. Hazırladığımız bir sorguyla birden çok kaydı aynı anda değiştirebilir,
silebilir veya verilerimiz üzerinde hesaplamalar yapabiliriz.
1. Temel İşlemler
a. Veri Tabanı Programını Kurma ya da Veri Tabanı Oturumuna Girme
Oluşturulan veri tabanı dosyalarında tüm kullanıcıların nesnelere erişimi ve üzerinde değişiklik yapmaları çok büyük problem oluşturabilir. Veri tabanı kullanıcı hesapları oluşturularak kullanıcılara veri
tabanındaki bilgi ve kaynaklara erişimde belirli ayrıcalıklar sağlanır. Grup hesabı, birkaç tane kullanıcı
hesabı içerir ve grubun veri tabanındaki nesnelere erişimini ve izinlerini denetlemek ve yönetmek için bir
yol oluşturur. Oturum açma işlemleri için aşağıdaki adımları takip edelim:
1. Daha önce oluşturduğumuz “Öğrenci İşleri” veri tabanını dosyasını açalım.
2. Araçlar menüsünden, Güvenlik seçeneğinden, Çalışma Grubu Yöneticisi’ne tıklayalım.
3. Açılan Çalışma Grubu Yöneticisi penceresinden Katıl’a tıklayalım (Resim 5.31).
4. Karşımıza gelen Çalışma Grubu Bilgi Dosyası penceresinden Tamam düğmesine tıklayarak
işlemlerimizi tamamlayalım (Resim 5.32).
Resim 5.31: Çalışma grubu yöneticisi penceresi
Resim 5.32: Çalışma grubu bilgi dosyası penceresi
b. Verilen Kriterlere Dayanarak Kayıt Bulma
Doğru bilgiye ulaşmak için elimizde bazı kriterler (ipuçları) olması gerekmektedir. Örneğin, bulunduğumuz şehirde binlerce kişi arasından ismini bilmediğimiz bir kişiye ulaşmak için onunla ilgili bazı
kriterler ortaya koyarak aradığımız kişiye ulaşmamız mümkündür. Kişinin cinsiyeti, yaş aralığı, yaklaşık
boyu, kilosu, teninin rengi, mesleği gibi kriterler listemizi binlerce kişiden birkaç kişiye düşürebilir.
Oluşturduğumuz veri tabanlarında da yüzlerce hatta binlerce kayıt arasından bazı özel kayıtlara
ulaşmamız gerekebilir. Bizim bu kayıtlara ulaşmamız için bazı koşullar öne sürmemiz gerekecektir. Veri
tabanı dosyamızda bu ihtiyacımız için Sorgu nesnesi kullanılmaktadır.
161
Bilgi ve İletişim Teknolojisi
c. Basit Bir Sorgu Oluşturma
MS Access veri tabanı programında ilk sorgumuzu oluşturmak için aşağıdaki adımları sırasıyla
uygulayalım:
1. Daha önce oluşturduğumuz “Öğrenci İşleri” veri tabanı dosyasını açalım.
2. Veri tabanı penceresi Nesneler bölümünden Sorgular seçeneğine tıklayalım.
3. Sağ taraftaki bölmeden Sihirbazı Kullanarak Sorgu Oluştur seçeneğine tıklayalım.
4. Basit Sorgu Sihirbazı ekranı açılacaktır (Resim 5.33).
İlk önce Tablolar ve Sorgular’dan hangi
tablodan veri alınacağını belirleyelim. Bu tablonun alan isimleri Kullanılabilir Alanlar bölümünde görüntülenir. Bu alanlardan kullanmak
istediğimizi seçelim ve Taşı (
) simgesine
tıklayarak Seçili Alanlar bölümüne alalım. Tüm
alanları silmek istersek Tümünü Taşı (
)
simgesine tıklayalım.
5. Tablolar ve sorgular bölümünden ÖĞRENCİ BİLGİLERİ tablosunu seçelim.
Resim 5.33: Basit sorgu sihirbazı 1. adım penceresi
6. Kullanılabilir Alanlar bölümünden “NUMARASI”, “ADI” ve “SOYADI” alanlarını seçelim ve
Taşı (
) simgesine basarak Seçili Alanlar bölümüne aktaralım ve İleri düğmesine tıklaya-
lım (Resim 5.33).
7. Sonraki ekranımızda bizden sorgumuzun ayrıntılı mı yoksa özet mi yapılacağını belirtmemiz
istenir. Ayrıntılı sorgu seçeneğini seçerek İleri düğmesine tıklayalım (Resim 5.34).
8. Yeni gelen pencerede sorgumuza başlık olarak “ÖĞRENCİ BASİT SORGU” metnini yazalım ve
Son düğmesine tıklayalım (Resim 5.35).
Resim 5.34: Basit sorgu sihirbazı 2. adım penceresi
162
Resim 5.35: Basit sorgu sihirbazı 3. adım penceresi
Veri Tabanı Uygulamaları
9. Oluşturduğumuz sorgu, ekranımıza gelecektir (Resim 5.36).
Resim 5.36: ÖĞRENCİ BASİT SORGUSU: Seçme sorgusu
ç. Çoklu Kriterlere Dayanarak Sorgu Oluşturma
Veri tabanımız binlerce kayıttan oluşabilir. Bunun için sorgulama yaparken çoklu kriterler koyarak
sınırlı sayıda verinin ekrana gelmesini sağlayabiliriz. Öğrenci İşleri veri tabanında kayıtlı “1994” yılından önce doğmuş “Erkek” leri sorgulamak için aşağıdaki adımları takip edelim:
1. “Öğrenci İşleri” veri tabanı dosyamız açıkken veri tabanı nesneler bölümünden Sorgular seçeneğine tıklayalım.
2. Sağ taraftaki bölmeden Tasarım Görünümünde Sorgu oluştur seçeneğine tıklayalım.
3. Ekrana Tabloyu Göster penceresi gelecektir
(Resim 5.37). Bu pencereden Öğrenci Bilgileri
tablosunu seçip Ekle düğmesine tıklayalım ve
daha sonra bu pencereyi kapatalım.
4. Bu aşamada sorguda kullanacağımız alanları
seçeceğiz. Tablomuzdan SINIFI, ADI, SOYADI,
DOĞUM TARİHİ, CİNSİYETİ alanlarına çift tıklayalım. Bu alanlarımız Sorgu tasarımı ekranına
Resim 5.37: Tobloyu göster penceresi
eklenecektir.
5. Tasarım penceremizi Resim 5.38’deki gibi dolduralım.
Resim 5.38: Sorgu tasarım penceresi
163
Bilgi ve İletişim Teknolojisi
6. Dosya menüsünden Kaydet seçeneğine tıklayalım ve sorgumuza “ERKEKLER <1994” ismini
verelim. Sorgu tasarım ekranımızı kapatalım.
7. Sorgulardan “ERKEKLER <1994” ismini çift tıklayarak sorgumuzun açılmasını sağlayalım. Karşımıza Resim 5.39’daki gibi bir pencere gelecektir.
Resim 5.39: ERKEKLER <1994 Seçme sorgusu
Çalışma Etkinliği
ÖĞRENCİ BİLGİLERİ tablosunda numarası 300’den küçük kayıtları gösteren bir sorgu
oluşturunz.
d. Sorguyu Kaydetme
Oluşturduğumuz veya üzerinde değişiklikler yaptığımız sorguyu kaydetmek için aşağıdaki seçeneklerden biri kullanılabilir:
1. Dosya menüsünden Kaydet komutunu seçmek.
2. Klavyeden CTRL+S tuşlarını kullanmak.
3. Standart Araç Çubuğunda yer alan Kaydet (
) düğmesine tıklamak.
e. Filtreler Ekleme
Veri tabanı penceresinden Sorgular nesnesine tıklayalım ve “ERKEKLER <1994” sorgusunu açalım.
1. SINIFI alanında bulunan bilgilerden
11/C yazan bir verinin üzerinde sağ
tıklayalım ve gelen menüden Seçime
Göre Filtre Uygula seçeneğine tıklayalım (Resim 5.40).
Resim 5.40: Filtre ekleme
164
Veri Tabanı Uygulamaları
2. Ekranımızda yalnızca sınıfı “11/C” olan kayıtlar kalacaktır (Resim 5.41).
Resim 5.41: Filtre ekleme
Ek Bilgi
Seçtiğimiz veriye göre filtre uygulamanın bir diğer yolu ise Sorgu Veri Sayfası Araç Çubuğundan (
) simgesine tıklamaktır.
f. Filtreleri Kaldırma
Uyguladığımız filtreyi kaldırmak için herhangi bir kayıt üzerinde sağ tıklanır ve Filtre/Sıralama Kaldır seçeneği seçilir.
2. Sorguyu Arıtma
Daha önce oluşturulan sorgular üzerinde değişiklikler yapılabilir. Yeni alanlar eklenebilir veya var
olan alanlar sorgudan çıkarılabilir.
a. Sorguya Alanlar Ekleme
Daha önceden oluşturulan sorguya yeni alanlar eklemek için aşağıdaki adımları takip edelim:
1. Veri tabanı penceresinde Nesneler bölümünden Sorgulara tıklayalım.
2. Sorgulardan “ERKEKLER <1994” sorgusunu seçelim ve Tasarla düğmesine tıklayalım.
3. Açılan Sorgu Tasarım Görünümü penceresinde CİNSİYET alanı yanındaki boş olan Alan
kutusuna tıklayalım.
4. Alan adı olarak NUMARASI alanını seçelim (Resim 5.42).
Resim 5.42: Sorguya alan ekleme
Böylece artık sorgumuzda NUMARASI bilgileri de listelenecektir.
b. Sorgudan Alanları Kaldırma
Tasarım görünümünde sorgumuzun hangi alanının sorgudan kaldırılmasını istiyorsak o alanın Göster satırındaki
işareti kaldırılır. Sorgudan kaldırılmak istenen alanın fare yardımıyla seçilerek klavyeden Delete tuşuna basılması da diğer bir yöntemdir.
165
Bilgi ve İletişim Teknolojisi
3. Seçme ve Sınıflandırma
a. Verilen Kritere Dayanarak Verileri Seçme ve
Sınıflandırma
Veri tabanlarımızda sorgular oluştururken kullanacağımız ölçütler önemlidir. Sorgu tasarımı penceresi
açıkken ölçüt deyimini, alanınızın Ölçüt sütununa yazarak veya Deyim Oluşturucu’yu kullanarak girebilirsiniz
(Resim 5.43). Deyim Oluşturucu’yu görüntülemek için
Ölçüt hücresi üzerinde farenin sağ tuşu tıklanır ve açılan menüden Oluştur komutu seçilir.
Resim 5.43: Deyim oluşturucusu penceresi
Sorgu ve filtrelerde alan ölçütleri için aşağıdaki ifadeler kullanılabilir:
Alan Açıklaması
İfade
Sonuç
Öğrencinin Yaşı
> 15
15’ten büyük sayılar
Öğrencinin Boyu
< 145
145’ten küçük sayılar
Öğrencinin Soyadı
> “MERT”
Alfabetik olarak MERT’ten sonra gelenler
Doğum Tarihi
>#05.10.1998#
Doğum tarihi belirtilen tarihten büyükler
Doğum Tarihi
Between #10.02.1990#
And #16.10.1993#
Doğum tarihi belirtilen tarihler arası olanlar
Öğrencinin Cinsiyeti
Not “ERKEK”
Cinsiyeti ERKEK olmayan kayıtlar
Öğrencinin Yaşı
Not 16
Yaşı 16 olmayan kayıtlar
Öğrencinin Sınıfı
Not 9*
Sınıfı “9” karakteri ile başlamayan kayıtlar
Öğrencinin Adı
In(“Hakan”, “Ezgi”)
Adı “Hakan” veya “Ezgi” olan kayıtlar
Doğum Yeri
“Adana”
Doğum yeri “Adana” olan kayıtlar
Öğrencinin sınıfı
“10/A” Or “11/C”
Sınıfı 10/A veya 11/C olan kayıtlar
Doğum Tarihi
‘03.12.1993’ 03.12.1993 olan kayıtlar
Öğrencinin Sınıfı
Is Null
Sınıf bilgisi boş olan kayıtlar
Öğrencinin Sınıfı
Is Not Null
Sınıf bilgisi boş olmayan kayıtlar
Ek Bilgi
Deyim Oluşturucuyu açmak için Araç Çubuğundan Oluşturur (
nabilir.
166
) simgesine de tıkla-
Veri Tabanı Uygulamaları
b. Mantık İşlemlerine Dayanarak Verileri Seçme ve Sınıflandırma
Veri tabanında sorgu ve filtrelerde ölçütleri mantıksal işlemler kullanarak daha ayrıntılı bir sorgulama yapılabilir.
“ÖĞRENCİ BİLGİLERİ” tablosu kullanılarak sorgulama ya da filtreleme yapılabilir. Örneğin, ADI
verisi “A” ile başlayan veya DOĞUM TARİHİ “1993” verisinden küçük kayıtların listesini almak istersek
filtremizi Resim 5.44’teki gibi doldurmamız gerekir.
Resim 5.44: Verileri seçme ve sınıflandırma
Bu örneğimizi şu şekilde de değiştirebiliriz: ADI verisi “A” veya “M” harfi ile başlayanlar ve DOĞUM
TARİHİ “1993” verisinden küçük kayıtların listesini almak istersek ölçütleri Resim 5.45’teki gibi girmeliyiz.
Resim 5.45: Bir filtreleme örneği
Değerlendirme Soruları
1. Tam olarak belirlediğimiz koşulları karşılayan verileri bulmak ve almak için hangi veri
tabanı nesnesi oluşturulur?
A) Tablo
B) Sorgu
C) Form
D) Rapor
E) Makro
2. Veri tabanı kullanıcı hesapları oluşturularak kullanıcılara veri tabanındaki bilgi ve kaynaklara erişimde belirli ayrıcalıklar sağlamak için Araçlar menüsünden hangi seçenek kullanılır?
A) Şifreleme
B) Kullanıcı
C) Erişim D) Güvenlik
E) Seçenekler
3. Seçtiğimiz veriye göre filtre uygulamak için Sorgu Veri Sayfası Araç Çubuğunda bulunan simgelerden hangisi kullanılır?
A)
B)
C)
D)
E)
4. Ölçüt bölümüne yazılan aşağıdaki ifadelerden hangisi “Verinin değeri 16 olmayan kayıtlar” anlamına gelir?
A) Null 16
B) >16 <
D) Not 16
E) In 16
C) Between 16
167
Bilgi ve İletişim Teknolojisi
D. RAPORLAMA
Konuya Hazırlık
1. Veri tabını dosyamızda bulanan verileri neden kâğıt üzerine dökmek isteriz? Araştırınız.
2. Veri tabanında bulunan bilgilerin kâğıt üzerinde olmasının avataj ve dezavantajları nelerdir? Tartışınız.
MS Access Veri tabanı programında, veri ve bilgileri yazdırılmış bir biçimde sunmanın etkin bir yolu
Rapor nesnesi oluşturmaktır. Rapor üzerinde değişiklikler yaparak verileri görmek istediğiniz biçimde
çıktı alabilirsiniz.
1. Seçilmiş Verileri Belirli Bir Sırayla Ekranda ve Raporlarda Gösterme
Raporu oluşturmak için aşağıdaki adımları takip edelim:
1. Daha önce oluşturduğumuz “Öğrenci İşleri” veri tabanı dosyasını açalım.
2. Veri tabanı penceresi Nesneler bölümünden Raporlar seçeneğine tıklayalım.
3. Yan bölmeden Sihirbazı Kullanarak
Rapor Oluştur seçeneğini seçelim.
4. Rapor Sihirbazı ekranı açılacaktır
(Resim 5.46). Tablolar ve sorgular
bölümünden ÖĞRENCİ BİLGİLERİ
tablosunu seçelim.
5. Kullanılabilir Alanlar bölümünden
SIRA NU., DOĞUM TARİHİ, ADRESİ alanları hariç tüm alan adlarını tek
tek Taşı (
) simgesine basarak
Seçili Alanlar bölümüne aktaralım
ve İleri düğmesine tıklayalım.
Resim 5.46: Rapor sihirbazı 1. adım penceresi
6. Gelen pencerede raporumuzu hangi alana göre gruplandıracak isek
o alanı seçeriz. Biz burada “CİNSİYET” alanına çift tıklayalım ve daha
sonra İleri düğmesine basalım (Resim 5.47).
Resim 5.47: Rapor sihirbazı 2. adım penceresi
168
Veri Tabanı Uygulamaları
7. Açılan pencerede alanlarımızın ekranda hangi sırayla nasıl sıralanacağını belirleriz. Hiçbir değişiklik yapmadan İleri düğmesine tıklayalım (Resim 5.48).
Resim 5.48: Rapor sihirbazı 3. adım penceresi
8. Gelen pencere raporumuzun yerleşimiyle ilgilidir. Değişiklik yapmadan İleri düğmesine tıklayalım (Resim 5.49).
Resim 5.49: Rapor sihirbazı 4. adım penceresi
9. Sıradaki Stil ekranından “Kalın” stilini seçelim ve İleri düğmesine tıklayalım (Resim 5.50).
Resim 5.50: Rapor sihirbazı 5. adım penceresi
169
Bilgi ve İletişim Teknolojisi
10.Son ekranda raporumuza başlık olarak “CİNSİYET LİSTESİ” metnini yazalım ve Son düğmesine tıklayalım. Raporumuz belirlediğimiz kriterlere göre ekrana gelecektir (Resim 5.51).
Resim 5.51: Cinsiyete göre rapor oluşturma
2. Raporu Değiştirme
Daha önce oluşturduğumuz rapor üzerinde değişiklikler yapmak için aşağıdaki adımları takip edelim:
1. Veri tabanı penceresinde Nesneler bölümünden Raporlar’a tıklayalım.
2. Yan bölümden “CİNSİYET” raporunu seçelim ve Tasarla düğmesine tıklayalım.
3. Raporumuz tasarım görünümünde açılacaktır. Bu ekranda alan başlıklarımızın ve veri referanslarının yerini ve biçimini değiştirebiliriz.
4. Rapor sayfamızda Resim 5.52’deki gibi “CİNSİYET LİSTESİ” başlığını ortalayalım ve “NUMARASI” veri kutusunu biraz sola kaydıralım.
5. Araç çubuğundaki
simgesini kullanarak “CİNSİYET LİSTESİ” başlığını “Yeşil” ve alan
adlarını “Mavi” yapalım.
6. Dosya menüsünden Baskı Önizleme seçeneğine tıklayarak raporumuzun son hâlini görelim
(Resim 5.52).
Resim 5.52: Rapor tasarımını değiştirme
170
Veri Tabanı Uygulamaları
3. Sayfa Başlıkları ve Altlıkları Oluşturma
Sayfa Başlıkları ya da Altlıkları, her rapor sayfasının üstünde ya da altında bulunacak bilgilerdir. Tasarım görünümünde açık olan raporumuzun Rapor Üstbilgisi veya Rapor Altbilgisi bölümüne
Rapor Araç Kutusu üzerinde bulunan Etiket (
) simgesini kullanarak Başlıklar ya da Altlıklar
oluşturabiliriz.
Çalışma Etkinliği
Raporunuza “Atatürk Lisesi” metnini girerek Altlık oluşturunuz.
4. Verileri Gruplama
Daha önce oluşturduğumuz bir raporu Tasarım görünümünde açalım. Araç çubuğu üzerindeki Sıralama ve Gruplandırma (
) sim-
gesini tıklayalım ve Sıralama ve Gruplandırma
penceresinin açılmasını sağlayalım (Resim 5.53).
Bu kutudan gruplamayla ilgili gerekli değişiklikleri
yapabiliriz.
Resim 5.53: Sıralama ve gruplama penceresi
Değerlendirme Soruları
1. MS Access Veri tabanı programında, veri ve bilgileri yazdırılmış bir biçimde sunmak için
aşağıdaki veri tabanı nesnelerinden hangisi oluşturulur?
A) Tablo
B) Sorgu
C) Form
D) Rapor
E) Makro
2. Oluşturulan raporun son hâlini görmek için Dosya menüsünden aşağıdaki komutlardan
hangisi seçilir?
A) Yazıcı B) Son Görünüm
D) Sayfa Yapısı
E) Düzen
C) Baskı Önizleme
3. Raporumuzda Sıralama ve Gruplandırma yapmak için Araç Çubuğu üzerinde bulunan
aşağıdaki simgelerden hangisi tıklanır?
B)
A)
C)
D)
E)
4. Raporun Üstbilgi veya Altbilgi bölümüne Başlıklar ya da Altlıklar oluşturmayı sağlayan
Etiket düğmesi aşağıdakilerden hangisidir?
A)
B)
C)
D)
E)
5. Raporun tasarımında yapılan değişiklikleri kaydetmek için aşağıdaki menülerden hangisi kullanılır?
A) Dosya
B) Düzen
D) Ekle
E) Araçlar
C) Biçim
171
Bilgi ve İletişim Teknolojisi
ÜNİTE SONU DEĞERLENDİRME SORULARI
A. Aşağıda verilen cümleleri uygun ifadelerle tamamlayınız.
1. Bir konuyla ilgili çok sayıda verilerin tutulmasına, depolanmasına ………………………… denir.
2. Veri türü “METİN” olarak belirlenen alanlara maksimum ………………………… karakter bilgi alınır.
3.…………………… nesnesi tablolardaki bilgileri belirli düzende kâğıda dökebilmek için kullanılır.
4.………………………… alan türü, alfabetik ve sayısal türde her türlü bilgi veya işlem gerektirmeyen
bilgilerin girilebildiği alan türüdür.
5. Bizim tam olarak belirlediğimiz koşulları karşılayan verileri bulmak ve almak için bir ………………
nesnesi oluştururuz.
6. Tasarım görünümünde, sorgumuzun hangi alanının sorgudan kaldırılmasını istiyorsak o alanın
………………………… satırındaki
işaretini kaldırırız.
7. Dizin yapısı oluşturmak için …………………………menüsünden Dizinler seçeneğine tıklanır.
8. Tablo tasarım görünümünde bir satır eklemek için eklenecek satır üzerinde sağ tıklanır gelen menüden ………………………… seçeneği seçilir.
9. Tablomuza kayıt girişi sırasında bulunduğumuz alanda yaptığımız değişiklikleri iptal etmek için klavyeden ………………………… tuşuna basarız.
10. Formumuza resim eklemek için Ekle menüsünden ………………………… seçeneğine tıklarız.
11.…………………………, birkaç tane kullanıcı hesabı içerir ve grubun veri tabanındaki nesnelere erişimini ve izinlerini denetleme ve yönetme için bir yol oluşturur.
12. Üzerinde değişiklik yaptığımız Sorguyu kaydetmek için Klavyede Ctrl tuşu basılı iken …..................
tuşuna basarız.
13. Tabloda istenilen bir veriye göre filtre uygulanmak istenirse o verinin üzerinde sağ tıklanır ve gelen
menüden ……….....................………………… seçeneğine tıklanır.
14. Uygulanan filtrenin kaldırılması için herhangi bir kayıt üzerinde sağ tıklanır ve …………...………………
seçeneği seçilir.
B. Aşağıdaki sorularda doğru yanıtı işaretleyiniz.
1. Alanlarla ilgili aşağıdaki özelliklerden hangisinde Evet seçeneğini seçersek bu alana mutlaka bilgi
girilmesi gerekir?
A) Sıralı
B) Biçim
D) Gerekli E) Varsayılan Değer
C) Giriş Maskesi
2. MS Access uygulaması ekranında bulunan araç çubuklarını kaldırmak veya yenilerini eklemek için
aşağıdaki menülerden hangisi kullanılır?
172
A) Ekle
B) Biçim
D) Düzen
E) Görünüm
C) Dosya
Veri Tabanı Uygulamaları
3. Dizin oluşturmak için tablomuz tasarım görünümünde açıkken Araç Çubuğunda aşağıdaki simgelerden hangisine tıklanır?
A)
B)
C)
D)
E)
4. Kayıt silmek için klavyedeki aşağıdaki tuşlardan hangisi kullanılır?
A) Insert
B) Esc
D) Delete
E) Ctrl
C) Shift
5. Sorgu tasarım ekranında bir alana ölçüt olarak aşağıdakilerden hangisi yazılırsa sadece B harfi ile
başlayanlar listelenir?
A) “B*“ B) “B” C) “B-“
D) “B?” E) “B!”
6. Sorgu tasarım ekranında bir alana ölçüt olarak aşağıdakilerden hangisi yazılırsa bu alan boş olan
kayıtlar anlamına gelir?
A) Is Null
B) Is Not D) Is Not Null
E) Is Or
C) Not
7. Sorgu tasarım ekranında bir alana ölçüt olarak aşağıdakilerden hangisi yazılırsa bu alan boş olmayan kayıtlar anlamına gelir?
A) Is Null
B) Is Not
D) Is Not Null
E) Is Or
C) Not
8. Sorgu tasarım ekranında bir alana ölçüt olarak hangisi yazılırsa bu alanda verisi “Ekran” veya “Klavye” olan kayıtlar anlamına gelir?
A) In (“Ekran”, “Klavye”)
B) And (“Ekran”, “Klavye”)
C) Not In (“Ekran”, “Klavye”)
D) Is Not In (“Ekran”, “Klavye”)
E) Or (“Ekran”, “Klavye”)
9. MS Access’te veri tabanını kaydetmek için aşağıdaki simgelerden hangisi kullanılır?
A)
B)
C)
D)
E)
10. Bir veri tabanı dosyası oluştururken ilk olarak aşağıdaki nesnelerden hangisi oluşturulmalıdır?
A) Tablo
B) Sorgu D) Rapor
E) Makro
C) Form
11. Bilgi alanında metin türünün uzunluğu yeterli olmuyorsa aşağıdaki veri türlerinden hangisi kullanılır?
A) Metin
B) Köprü
D) Not
E) Evet/Hayır
C) OLE
173
Bilgi ve İletişim Teknolojisi
12. Deyim Oluşturucuyu açmak için form Sorgu tasarım görünümünde açıkken Araç Çubuğunda hangi
simgeye tıklanır?
A)
B)
C)
D)
E)
13. Yardım penceresini açmak için Veri Tabanı Araç Çubuğu üzerinde bulunan hangi simgeye tıklanır?
A)
B)
C)
D)
E)
BULMACA
1. Oluşturduğunuz tabloda bir alana mutlaka bilgi girilmesi için kullanılan alan özelliğidir.
2. Tablolardaki bilgileri belirli düzende kâğıda dökebilmek için kullanılır.
3. Tasarım görünümündeki formumuzda verilerin metin biçimini değiştirmek için kullanılan araç çubuğudur.
4. İnternet adresi gibi bir yere bağlantı kurulmasını sağlayan tablodaki bir alan için kullanılan veri türüdür.
5. Tablodaki belirli bilgiye hızlı erişmek ve Dizinler penceresini açmak için kullanılan menüdür.
2
1
5
3
4
174

Benzer belgeler